Here I join the multitude of "Nvidia error" questions, because I couldn't find anything that helped.

Background: For some reason my drivers (nvidia-experimental-310) stopped working, so I tried re-installing them. Also, the same thing happened when I tried installing nvidia-current-updates. Here's the log:

$ sudo apt-get install nvidia-experimental-310
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 1 to remove and 0 not upgraded.
Need to get 0 B/37.4 MB of archives.
After this operation, 1,758 kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 221035 files and directories currently installed.)
Removing nvidia-current-updates ...
Removing all DKMS Modules
update-alternatives: using /usr/lib/i386-linux-gnu/mesa/ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in auto mode
INFO:Disable nvidia-current-updates
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
DEBUG:Processing quirk ThinkPad T420s
DEBUG:Failure to match Dell Inc. with LENOVO
DEBUG:Quirk doesn't match
DEBUG:Processing quirk Latitude E6530
DEBUG:Failure to match Dell DXP051 with Latitude E6530
DEBUG:Quirk doesn't match
update-initramfs: deferring update (trigger activated)
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Processing triggers for man-db ...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.7.0-7-generic
Selecting previously unselected package nvidia-experimental-310.
(Reading database ... 220868 files and directories currently installed.)
Unpacking nvidia-experimental-310 (from .../nvidia-experimental-310_310.14-0ubuntu1_i386.deb) ...
Processing triggers for desktop-file-utils ...
Processing triggers for man-db ...
Setting up nvidia-experimental-310 (310.14-0ubuntu1) ...
update-alternatives: using /usr/lib/nvidia-experimental-310/ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in auto mode
update-alternatives: warning: skip creation of /usr/lib32/libOpenCL.so because associated file /usr/lib32/nvidia-experimental-310/libOpenCL.so (of link group i386-linux-gnu_gl_conf) doesn't exist
update-alternatives: warning: skip creation of /usr/lib32/vdpau/libvdpau_nvidia.so.1 because associated file /usr/lib32/nvidia-experimental-310/vdpau/libvdpau_nvidia.so.1 (of link group i386-linux-gnu_gl_conf) doesn't exist
update-alternatives: warning: skip creation of /usr/lib32/libvdpau_nvidia.so because associated file /usr/lib32/nvidia-experimental-310/vdpau/libvdpau_nvidia.so (of link group i386-linux-gnu_gl_conf) doesn't exist
update-alternatives: using /usr/lib/nvidia-experimental-310/alt_ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in auto mode
update-initramfs: deferring update (trigger activated)
INFO:Enable nvidia-experimental-310
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
Loading new nvidia-experimental-310-310.14 DKMS files...
Building only for 3.7.0-7-generic
Building for architecture i686
Building initial module for 3.7.0-7-generic
Traceback (most recent call last):
  File "/usr/share/apport/package-hooks/dkms_packages.py", line 22, in <module>
    import apport
ImportError: No module named apport
Error! Bad return status for module build on kernel: 3.7.0-7-generic (i686)
Consult /var/lib/dkms/nvidia-experimental-310/310.14/build/make.log for more information.
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.7.0-7-generic

So there's some "apport" error going on, whatever that means. Here's the make file log: http://paste.ubuntu.com/1464536/

Question: How do I solve this?

Additional Info:

  • Xubuntu 12.10
  • Nvidia GeForce GT430

If more info is needed, just let me know.


I removed the Xorg-edgers ppa, and uninstalled all the 3.7 kernel things using synaptic. Then I ran apt-get autoremove to remove any leftovers, apt-get update, and the apt-get install nvidia-current-updates, which still didn't work. Looking at the log from terminal, it seems that I don't have the source of the kernel or something.

  • 1
    12.10 uses the 3.5 kernel, and you seem to have 3.7. Are you sure you aren't beta testing or something? Dec 25 '12 at 14:29
  • I added the Xorg-edgers ppa because that helped solve some issues with the Steam Linux Beta. I'll boot into a 3.5 kernel, uninstall the 3.7 kernels, and try re-installing the drivers.
    – ananaso
    Dec 25 '12 at 16:43

Alright, so here's what was causing the real problem in the end.

First of all, as mikewhatever said, 3.7 is a non-standard/unstable kernel, and as such doesn't really need to be used. In light of this, I:

  1. Removed the Xorg-edgers PPA
  2. Removed the 3.7 kernels and all the guff that went along with them
  3. sudo apt-get update
  4. sudo apt-get upgrade

But that was still causing problems, although a slightly different one. As you can see near the bottom of the terminal log, it says

Module build for the currently running kernel was skipped since the kernel source for this kernel does not seem to be installed.

So I opened synaptic to see what was installed for the kernels, doing the following:

  1. Limit search to linux-*-3.5.0-19
  2. Mark linux-headers-3.5.0-19-generic for installation
  3. If it wasn't selected automatically, select linux-headers-3.5.0-19 as well
  4. Install

After I did this (and restarted my computer to be safe), I ran sudo apt-get install nvidia-current-updates in terminal, and this time it correctly installed! I then restarted my computer, and voila! Everything was working!

The moral of the story: avoid using non-standard kernels.

Thanks again to mikewhatever for leading me on the right track.

  • How did you remove 3.7 kernal and all the 'guff'? And I dont see Xorg-edgers PPA on my system. Help!
    – Guided33
    Jan 22 '13 at 7:29
  • if I run uname -r it shows me 3.7.0-7-generic, what is the procedure for switching to 3.5* and removing 3.7?
    – Guided33
    Jan 22 '13 at 7:35
  • 1
    In synaptic, try searching for linux-*-3.7.0-7, and it should show them. You'll probably want to remove the 3.7 linux headers and 3.7 generic linux headers. Then make sure you also have the 3.5 kernel installed, and once that's all been removed/installed, run sudo update-grub in terminal. Also, if you're looking in Software Sources for the Xorg-edgers PPA, sometimes things aren't listed there, so you might want to look up other places to look as well.
    – ananaso
    Jan 23 '13 at 2:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.