2

I am trying to enable touchpad multitouch/scrolling in Ubuntu 12.04 on my Dell Inspiron 5720 (17R). By default after installation it had the following settings (xinput results):

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech Unifying Device. Wireless PID:101b   id=11   [slave  pointer  (2)]
⎜   ↳ PS/2 Generic Mouse                        id=14   [slave  pointer  (2)]

So I followed this tutorial: https://askubuntu.com/a/211755/113496

After installing the package stated there using install.sh here is installation log:

konnigun@konnigun-Inspiron-5720:/usr/src/psmouse-alps-dst-0.4$ sudo bash ./install.sh
MAIN: Driver source files by Dave Turvene. Install script by garyF.
MAIN: Removing previous versions of psmouse-alps-dst...

-------- Uninstall Beginning --------
Module:  psmouse
Version: alps-dst-0.4
Kernel:  3.2.0-35-generic (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

psmouse.ko:
 - Uninstallation
   - Deleting from: /lib/modules/3.2.0-35-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod.........

DKMS: uninstall completed.

------------------------------
Deleting module version: alps-dst-0.4
completely from the DKMS tree.
------------------------------
Done.
MAIN: Building current driver from source files...

Creating symlink /var/lib/dkms/psmouse/alps-dst-0.4/source ->
                 /usr/src/psmouse-alps-dst-0.4

DKMS: add completed.

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area....
make KERNELRELEASE=3.2.0-35-generic -C /lib/modules/3.2.0-35-generic/build M=/var/lib/dkms/psmouse/alps-dst-0.4/build/src psmouse.ko......
cleaning build area....

DKMS: build completed.
MAIN: Installing the driver

psmouse:
Running module version sanity check.
 - Original module
 - Installation
   - Installing to /lib/modules/3.2.0-35-generic/updates/dkms/

depmod....

DKMS: install completed.
rmmod psmouse, wait=no
insmod /lib/modules/3.2.0-35-generic/updates/dkms/psmouse.ko 
MAIN: Done installing. Go to System Settings > Mouse and Touchpad to configure :-)

My touchpad got totally disabled. I mean, it doesnt work at all. But xinput now gives the following:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech Unifying Device. Wireless PID:101b   id=11   [slave  pointer  (2)]
⎜   ↳ PS/2 Mouse                                id=14   [slave  pointer  (2)]
⎜   ↳ AlpsPS/2 ALPS GlidePoint                  id=15   [slave  pointer  (2)]

But touchpad doesn't work. What can I do to fix it? Thanks alot =)

UPD:
After updating Kernel from 3.2 to 3.5 it began working but in a very strange way: only scrolling and Fn+F3 began to work. Scrolling is working very strange. Nothing else works (I mean no two-finger scrolling and stuff like that). So basically I have a usual touchpad behavior now + scrolling.

1
  • 1
    You either have side scrolling or two finger scrolling but not both. You have to choose from the mouse configuration panel.
    – alfC
    Commented Dec 26, 2012 at 0:33

1 Answer 1

1

Okay, after spending half of a day solving this puzzle here is what I got: Neither v0.4 or v1.0 installation from http://www.dahetral.com/public-download worked for me, touchpad just wasn't working it all.
So I upgraded kernel from 3.2 to 3.5 by doing this:

sudo apt-get install linux

Which actually installed the following packages:
- linux-header-3.50-030500 - linux-header-3.50-030500-generic - linux-image-3.50-030500-generic

After that I tried and reinstalled 0.4 version (using 1.0 version right now though) and it started working. What is strange: I didn't even reboot in new kernel, I installed driver with new kernel installed, than I purged it and everything works. Can't quite understand why it's like that.

Also I wanna say thanks to alfC for reminding me to check touchpad settings in system menu, totally forgot bout that.

1
  • Awesome, this did it for me :) !
    – user204762
    Commented Oct 23, 2013 at 16:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .