The login and Unity Greeter is working. However, if I try to log-in - in a matter of seconds, it would return to the login screen.
This happened when I tried to install a package and I restarted my computer.

I also tried to uninstall, install, re-install, upgrade the lightdm, gdm and gnome.

I installed/reinstalled Ubuntu Desktop/Cinnamon/Gnome3 as well, to try and see if it would work. But it is still the same and I can see the login-lockscreen.

In a matter of seconds, I'll be back to the log-in screen.

  • Does opening a guest session work? – Béné Dec 25 '12 at 11:18
  • "This happened when I tried to install a package" - What package did you install? – gertvdijk Dec 25 '12 at 12:02

At the login screen, use ctrl-alt-f1 to get to a tty login. Login, then delete ~/.Xauthority . If the X server did not shut down properly during the crash, the orphaned lock file is preventing you from starting X.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.