I have a Logitech which I remember to be working fine from skype some releases, ago, since Lucid it is not functional from skype. The /dev/video0 from the webcam shows up on the skype device list but the test function procudes no results.

It works fine from cheese so it's not a kernel driver issue, any idea on what could be the problem for skype ?

| improve this question | | | | |

Well for me the issue was solved with my logitech which is slightly different that yours.

I have Logitech, Inc. QuickCam E2500 series but have always had skype problems until I edited the main menu entry and inserted a special command Here is how:

First access Main Menu via your special key (windows logo) and type 'Main Menu' Up comes Main Menu,click on that and then under Menus>Internet you will see Skype. Left Click on Skype and on the right hand side select Properties. Here is the name and command used to open Skype as well as the icon etc etc

In the command box paste the following command as it is written below:

bash -c 'LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype'

Select close and shut down the menu

Now when you open skype your web cam should function

Try back in Skype> options>Video Devices Hopefully now where it allows you to select webcam it should say something like USB Camera (o46d:089d) Hit test and see what happens. Let me know if this helps or not This has been a continual pain in the rear for Skype /Logitech users which used to be solved by opening using the same command in the terminal but that is SO boring so adding it to your menu entry does it for you.

| improve this answer | | | | |
  • 1
    Please note that this has changed for 11.10 and now you have to insert the following: bash -c 'LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype' – andybleaden Oct 15 '11 at 7:06
  • 1
    I tried that, it doesn't show an error anymore but it doesn't work either. The only way to make it work is to use Share Screen over top of the Cheese window. – Patrick Dec 5 '11 at 2:44
  • I have a different Logitech webcam model, but this solution also worked for it in Ubuntu 12.04 (Using same path as for 11.10) and skype – adosaiguas Aug 29 '12 at 17:31

Sometimes the 'test video' function from skype doesn't work for me, but then in a call I'm able to use my webcam. Try to place a video-call (to another skype user) and see if it works, because it should. And I noticed I have to plug in my webcam before I start skype.

| improve this answer | | | | |

I have faced some problems with webcam in skype and other software in the past, which can be read in the next forums:


I have tried (successfully) the "Flashcam Project", which is really well documented in the official website at:


This might help.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.