I hope, I can get an answer, I didn't find any related topic, so I decided to make a new one... So I tried to install several applications like Neverball or SuperTux and they do install, but in fact i always get a segmentation fault, when i try to run these programs... So is there a way to fix this.

I tried a few things... Whether I installed it with apt-get install or by using the Software center, it installs, but it doesn't run, neither using the command line nor clicking on the corresponding icons.

This problem doesn't for instance apply to OpenOffice, it seems especially games won't run...

Here for instance the output for supertuxkart:

Irrlicht Engine version 1.7.3
Linux 3.5.0-21-generic #32-Ubuntu SMP Tue Dec 11 18:51:59 UTC 2012 x86_64
[FileManager] Data files will be fetched from: '/usr/share/games/supertuxkart'
[FileManager] Addons files will be stored in '/home/username/.local/share/supertuxkart/addons'.
[translate] Env var LANGUAGE = 'de_DE.UTF-8'
[translate] Env var LANGUAGE = 'de_DE.UTF-8', which corresponds to 'German (Germany)'
Adding language fallback de
[IrrDriver] Trying OpenGL rendering.
Speicherzugriffsfehler (segmentation fault)

The output for sudo lspci | grep VGA:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Caicos [Radeon HD 6400M/7400M Series]

note that purging fglrx and reinstalling the proper versions of libGL and libglx will not solve the problem at all...

  • Please provide some more information. How did you install them? (apt-get? Synaptic? Ubuntu Software Center?) How are you trying to run them? (command line? menu item?) – voithos Dec 24 '12 at 23:08
  • yes, i tried all of those ways... – mathematiker Dec 24 '12 at 23:15
  • Were there any errors when you installed? What was the output of apt-get? Exactly what error is being thrown? The problem is that there are many, many different things that could be causing it. Basically, try to give us all of the information that seems relevant, and no more. – voithos Dec 24 '12 at 23:19
  • ok, i put now the output of one of the programs indicated... in the installation process everything went okay... – mathematiker Dec 24 '12 at 23:26
  • It looks to be failing when trying to render OpenGL. I don't know how well the default drivers work. Have you switched your video driver? If not, you may want to. – voithos Dec 24 '12 at 23:37

Try installing the proprietary ATI drivers for your video card (called fglrx). You can find a fairly comprehensive how-to guide on this. As the guide itself says, however, the easiest way may be to use the Hardware Drivers manager. I'm not sure if this is accurate, but according to an earlier answer, the drivers manager can be found in Lubuntu under Preferences > Software Sources > Additional Drivers (as of Quaztal).

  • This seems to be even more messed up then I thought, this probably will work for most of the others with the same problem, but for me, it kind of won't. I can install the fglrx package, but when i go for fglrxinfo I receive yet again a segmentation fault – mathematiker Dec 25 '12 at 11:56
  • @Matthias: Someone else seems to have had this problem, but they didn't have a Radeon card. What's the output of sudo lspci | grep VGA? – voithos Dec 25 '12 at 17:19
  • i added the output to my question... unfortunately, the solution described in the link won't work for me. – mathematiker Dec 25 '12 at 23:33
  • I'm not sure whether this can help you, but I noticed that the xorg.conf file is empty... – mathematiker Dec 26 '12 at 12:41
  • @Matthias: That's not unheard of; nowadays the X server will try to auto-detect anything it can, so the xorg.conf file is only necessary when you need to override something. Question: before you switched to fglrx, was your system running on the Open-Source driver? – voithos Dec 26 '12 at 16:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.