8
votes

I have a dual boot and a I configured windows to use UTC with a registry fix as explained in here: Clock time is off on dual boot

Now, I need to come back to localtime again, and I have no idea about how to edit the windows' registry to make it use local time again.

5
  • What version of Windows?
    – david6
    Dec 24 '12 at 20:43
  • 2
    This question is asking for help reversing changes explained in a procedure documented in an Ask Ubuntu answer and in the Ubuntu community wiki. Ordinarily Windows questions should be closed as off-topic, but in this case, I do not think we should close this as off-topic. However, it might be reasonable to add information about how to reverse the Windows registry edit in that answer to that answer itself, and then make this a duplicate of that question. Dec 25 '12 at 4:57
  • @EliahKagan Would it be better to add it also to the wiki, so the content is there for all?
    – nanofarad
    Dec 25 '12 at 15:07
  • @EliahKagan It is added, and was easier than expected. The DWORD value should have been set to 0 to undo it.
    – nanofarad
    Dec 25 '12 at 18:33
  • @ObsessiveSSOℲ Cool--thanks for adding it to the community wiki! Dec 25 '12 at 18:36
4
votes

On my Windows 7 machine, the default is for HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\RealTimeIsUniversal to not exist. So, here are Windows instructions:

Hold down the Windows logo key and press R. There, type regedit. Click OK and if you're using Vista or newer, acknowledge the UAC warning.

Now, in the left pane, there is a tree view. Under Computer, there will be some things called HKEY_SOMETHING_OR_OTHER. You should click the + next to HKEY_LOCAL_MACHINE. Then, you should click the + next to SYSTEM to get ino HKEY_LOCAL_MACHINE\SYSTEM. Now, expand CurrentControlSet, then inside it, Control, and then TimeZoneInformation. Now, right-click the entry for RealTimeIsUniversal and select the option to delete it. Alternatively, you could set it's value to 0.

10
  • Worked fine (in my case it was Windows XP). Thanks for the answer and for adding it to the wiki to make it available for everyone! Dec 25 '12 at 20:19
  • Note that this registry setting is no longer honored in Windows 8+.
    – brianary
    Oct 5 '14 at 20:52
  • 1
    @hexafraction I wish i knew of any. So far, all signs point to this being a completely dropped feature.
    – brianary
    Oct 5 '14 at 20:58
  • 1
    …and it still doesn't work in Windows 10. 😒
    – brianary
    Aug 9 '15 at 2:08
  • 4
    If hexafraction's answer didn't work, you're probably running a x64 Windows. You need to go thru the same steps, but create a QWORD value (instead of DWORD).
    – maaw
    Jun 30 '16 at 0:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.