I have a 60Gb drive in a Dell Latitude D600. It all started with trying to install 10.10 as a dual boot. First installation failed at the partitioning stage, next I tried manual partition that also failed. I finally went to Gparted LiveCD to see what I could do.

It allows me to shrink the NTFS, create a swap partition, create a partition in the remaining space. If however I try to format the empty partition as ext3 or ext4 it fails, the drive disappears from Gparted and I have to reboot. When I come back in, the blank space is there with no file system.

If I try to format the new partition in NTFS or Fat32 (as a test) it works fine and Windows can see it.

I even tried creating a FAT32 partition, doing and Ubuntu install to that disk, allocating almost all of it to Ubuntu (thinking I could use the small remainder as a shared disk), it started the install but failed after several minutes of copying with a warning about can not fsync (something) and something about RW problems.

(clarification because based on comments I thoroughly confused the issue, I didn't actually try to install to the FAT32, I just thought that it was odd that Gparted was successful in creating it, so kept the FAT32 which I thought was ok then let the installer shrink it and do whatever it wanted which was of course creating a ext4 beside the shrunken partition. This was an academic exercise since nothing was working anyway and thank all for pointing out my mistaken wording)

At this point I can't install Ubuntu because there seems to be now way to create a suitable partition.

  • 1
    1. Is the drive healthy? Have you looked at its SMART data or something? 2. Does GParted give you an option to save a log of the failed attempt to make a filesystem (it should)? If so, what does the log say? – arrange Jan 25 '11 at 17:17
  • I was able to get it re-partitioned and formatted in ext4 using a usb adapter and another Ubuntu computer, but now the SMART data is looking bad. Maybe best bet is to bail on this one and get a new drive. – Dennis Jan 25 '11 at 18:07
  • 1
    You can not install Ubuntu to fat32 or ntfs since they do not support posix file semantics. It sounds like your disk is fubar. Check your kernel log for error messages ( run dmesg or look at /var/log/kern.log ). – psusi Jan 25 '11 at 18:46

This sounds like you have a physically defective drive, or a defective live cd. The installer uses libparted to do it's formatting/partitioning work, so if that has a corruption then it could cause the disk to fail to partition in both gparted and the installer.

We will need more logs to see more of what's going on. Please report gparted errors and if possible, run from the command line.

On installing on FAT32, the problem is that Linux requires a modern file system with linking, per file permissions, etc. Windows file systems like FAT and NTFS never had these features and so it's not possible to install Ubuntu on them. Other file systems like btfs, ext2, xfs etc however are possible to use.

  • 2
    It does not use gparted. gparted is a gui program built on the library from GNU parted. The installer also uses libparted, but beyond that, has nothing to do with gparted. – psusi Jan 25 '11 at 18:44
  • 1
    Yes, I know that, but I wanted to make it clear they were related. But I've still taken your advice and pedantically updated the answer. – Martin Owens -doctormo- Jan 25 '11 at 18:46
  • Based on continuing and increasing errors I'm going with bad HD and will try another later. – Dennis Jan 25 '11 at 21:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.