I'm running HDMI video and audio from the on-board ATI graphics output of a GIGABYTE GA-MA78GM-S2HP motherboard to an Philips TV. It works fine, but every once in a while the screen will go blank and I can't seem to get it back without reseting the computer. The screen saver and power modes don't seem to cause it and I tried disabling them to no avail.

Does anyone have any tips on how I could (a) reset the video output without a hard CPU reset, (b) gather more data to troubleshoot the problem and/or better yet (c) know what could be causing this issue?

I have replaced the 19" TV with a 24" HDMI monitor and have not had a reoccurrence of this problem since that time.

  • Please update your question as you gather new info, per the latest update your system is freezing. – João Pinto Dec 1 '10 at 23:19


Have you tried to restart X?. You can do it from the terminal (switch using CTRL+ALt+F1) and writing:

/etc/init.d/gdm restart


service gdm restart

If this doesn't work you could try to unload/load the graphic card module from the kernel, but this can a little tricky as usually there are a couple of modules depending one on another. You can start typing lsmod in a terminal to see what modules you have loaded. You can force modules to unload using rmmod as root and load them again with modprobe.


Have you looked at the system and X.org logs?. You can check them on System->Administration->System Logs or in /var/log/. The needed info is likely shown at the bottom of a dmesg command right after the problems happen.

  • Next time it happens I will try to ssh into the box from another machine. Since the display goes out it is hard to open a terminal and run commands (if it is even responsive). ;) – Judge Maygarden Aug 18 '10 at 13:34
  • You can view older logs easy with the System Log utility. – Javier Rivera Aug 18 '10 at 14:16
  • It's not X, or at least it isn't only X that fails. I can't switch to a terminal or ssh from another computer on the network when it happens. – Judge Maygarden Sep 2 '10 at 1:55
  • Have you looked at old logs?. There must be some clue there. – Javier Rivera Sep 2 '10 at 6:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.