My old computer is used by my mother now. I have installed Lubuntu 12.04 on it (on 2012.11.02), replacing the old, but perfectly working Lubuntu 11.04. After installing 12.04, it was OK for a while, but after a time, I think, there were some software updates, and resolution fall back to 640x480. I have tried many fixes.

  • open source nvidia driver (nouveau, nvidia-96, experimental 310)
  • previous version of nvidia driver...
  • edit xorg.conf (the best result was that I copied the existing xorg.conf from my desktop computer, and with it, there is a 1280x1024 resolution, which still not fits to this widescreen monitor)

But no success.

The VGA card is a FX5200, which is supported by Nvidia 173 driver... But if it is supported, why is maximum resolution 640x480 with it? (I noticed, too, that my monitor is also unknown by the system.)

Strange problem, too : the nvidia-settings is now reporting that the nvidia driver is too old, and he can't use it, even if there is the latest nvidia driver installed.

I can agree with the open source driver, this computer is not used for gaming, or such things. So I only want a resolution, fitting to the widescreen monitor (1280x768, 1280x720, or 1440x900).


Don't forget that when you install nvidia-current (or updates) then the nvidia-settings program also gets installed. It's often necessary to run nvidia-settings, select the best resolution, then tell it to save the configuration (actually, it saves /etc/X11/xorg.conf).

If you still have problems look in the /etc/X11/xorg.conf and see if it's tried to set VertRefresh and HorizSync to rediculously low settings that only allow 640x480 resolutions to be selected. It's a bug that I've been coming across, from time to time, but it's hard to say what triggers it. If the screen is working OK apart from the resolution then this is worth a look.


Based on the data in your xorg.conf, it looks like you are trying to acheive 1440x900 at 60Hz. Running cvt with these parameters gives a modeline of

Modeline "1440x900_60.00"  106.50  1440 1528 1672 1904  900 903 909 934 -hsync +vsync

You should delete or comment out the metamodes (never found them useful) and instead substitute this mode line. Restart X and see if it gives you option to change to this resolution.

  • Hi, Hsync and Vsynd is tried to set from EDID, and from constant values written to the xorg.conf, but no success :( Nvidia-settings is installed, but if i start it with nvidia-173, it says that the driver is too old for use with Nvidia-settings (???), or with the open source driver, it says that there is no nvidia driver on the system :S I will try to modify screen clock values, it is OK for a try! Thanks :) (I have been Googled around for days, and i see that this is a serious bug, but i hope that there will be a solution - 12.04 was released half a year ago...! – ColT Dec 24 '12 at 10:38
  • The editing of frequencies had no effect. I cannot see any other resolutions or refresh freq's. :( The main problem, i see, that is - If i change something in xorg.conf, it has no effect... - Nvidia-settings cannot start, it ignores the nvidia driver, even if the binary is activated. Can anyone tell a solution to these problems? I will send the xorg.conf to pastebin, and link it there, so if someone can see the error in that... The xorg.conf on pastebin : pastebin.com/WqL3Ygqw – ColT Dec 24 '12 at 11:58
  • I have tried that modeline ( Modeline "1280x768_60.00" 79.50 1280 1344 1472 1664 768 771 781 798 -hsync +vsync ) but it resulted in an "Out of frequency" message from the monitor. I have logged in on VNC to the machine, and see that resolution is set to 2048x1536, and in LXrandr, there was no "1280x7608" option. I looked after the monitor, it can display 1440x900 (will be better), and Hsync 30-80khz, Vsync 55-75Hz. – ColT Dec 24 '12 at 12:51
  • You can generate your own modelines, for example the command "cvt 1440 900 60" gives the new modline of "Modeline "1440x900_60.00" 106.50 1440 1528 1672 1904 900 903 909 934 -hsync +vsync". Give that one a go and see if it works any better (the fact that you could change what was happening with the modeline is a good thing - its just a matter of getting it right. – fabricator4 Dec 24 '12 at 13:02
  • OK, the modeline for 1280x768 is working! :) Thanks for help :) Other problem : the 1280x760 is not perfcet, can someone generate a modeline for 1280x720 or 1440x900? I tried, but it resulted in useless display, or Out of range :S (I don't understand, why, i gave cvt the parameters 1280 720 60 and 1440 900 60...) – ColT Dec 24 '12 at 13:30


If the user's screen features a 1440x900 resolution, the xrandr-based Indicator ScaleRes will add (as extra resolutions) 1585x991, 1800x1125 and 1872x1170, basically, multiplying the native screen resolution by 1.10, 1.25, 1.30

I have not had the same problems as you, though I have Lubuntu on an old machine with Nvidia as well. I can only use the stock Ubuntu driver, because the driver that would work for my machine nvidia-96 depends on xorg-video-abi-10 which unfortunately doesn't exist... whoops. This bug also affects YOU. Look through this bug report for more details.


  • I had the xorg-xvideo-abi-10 problem, but it is solved by a small hack package, by diehard67 :) I have installed nvidia-96 , but can't set the correct resolution. I will try ScaleRes. – ColT Dec 23 '12 at 20:02
  • I have tried scaleres, but it doesn't start. And i don't want to scale the screen, but set the correct resolution :D Monitor's native is 1440x900, but 1280x768 is also suitable. – ColT Dec 23 '12 at 20:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.