1

After reinstalling my Ubuntu (right now I have 12.04.1) I'm trying to install SPAZ, but when I run the installer:

gacek@gacek-Vostro-3460:~$ ./spaz-linux-humblebundle-09182012-bin 
bash: ./spaz-linux-humblebundle-09182012-bin: No such file or directory

it says there's no such file. But it exist. I've tried to change the ownership of the file, change the access flags for it. The executable flag is also enabled.

Where could be the problem?

Regarding the question, the file exists and it is NOT a directory:

gacek@gacek-Vostro-3460:~$ ls -g
razem 168776
drwxrwxrwx  2  1000      4096 Dec 22 23:25 Desktop
(...)
-rwxr-xr-x  1 gacek 157466422 Sep 19 01:15 spaz-linux-humblebundle-09182012-bin
  • are you sure this spaz-linux-humblebundle-09182012-bin is not a DIRECTORY? – Rinzwind Dec 23 '12 at 16:10
  • yes, I'm sure. It is a binary file (executable). Before the reinstallation I successfully installed the SPAZ just by executing the file. Right now I cannot and I don't know why – Gacek Dec 23 '12 at 16:13
-2

I think that it's just a permission matter, just run this command:

chmod +x spaz-linux-humblebundle-09182012-bin

and then again:

./spaz-linux-humblebundle-09182012-bin
  • It already has the executable flag - take a look at the ls – Gacek Jun 1 '13 at 17:37
-2

Rename it sudo mv spaz-linux-humblebundle-09182012-bin spaz.exe then launch it with Wine

-2

This worked for me on xubuntu 16.04:

sudo apt-get install lib32z1
  • sorry mate, worked but partially, i installed playonlinux and now works fine. – user550734 Jun 1 '16 at 16:58
  • btw command is sudo apt-get install playonlinux – user550734 Jun 1 '16 at 17:00

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.