I've renamed this to reflect what I've learned. The details below track the issue.


I'm trying to install a set of OpenType Helvetica fonts. The font installation is failing because the "Thin" fonts are described in the font properties as "Light", triggering a "this font is already installed on your system" error.

  1. When I open either font in KFontView, the font name is "Helvetica, Light".
  2. When I click on File Properties and go to the "Information" tag, the "Font.Weight" is "Light" for both fonts.
  3. When I open up the fonts in FontForge, the Thin font says "Thin" and the Light font says "Light".
  4. When I save the thin font as an sfd file from FontForge and open it in Kate, the string "Light" can't be found.
  5. When I open up the thin font binary (oft) in Kate the string "Light" can't be found.

I'm pretty sure I want to change the font.weight property of the Thin files to be "Thin" so that a) I can install them and b) their metadata will be correct. But for the life of me I can't figure out where the font properties on the properties dialog are even stored; much less how to change them.

The only potential solution I've come up with so far (and I haven't tried it) is to install the Thin fonts, go into the font-config database to correct the names, and then install the Light fonts. Aside from being a PITA and presumably losing my changes if I have to reinstall the fonts, this just seems like a Bad Idea.

I'm happy to provide more information as requested.

REVISION (27 JAN 2010)

Additional information:

  1. This is strictly a Qt or KDE issue. Moving the fonts into /usr/local/share/fonts and then calling "fc-cache" installs the fonts just fine. These fonts still don't appear in the KDE Font Installer, however.

  2. Looking (lightly) at the source code, the font metadata that is messing up KDE is possibly stored in the UDS. There are too many generic terms for Google to be much help; so I'm not sure if the UDS is owned by the filesystem (ext3), the Qt toolkit, or (not likely) by KDE.

  3. KMail treats fonts like MS Office on Windows. It hides all but the font family from the user and expects to find just bold, italic, and bold italic styles. It's not much use for testing this issue.

  4. OpenOffice is better in that it shows the font families in the toolbar but shows all the styles in the text properties dialog. Unfortunately this code appears to be buggy; changing the style to anything other than the basic bold and italic didn't work.

  5. Scribus treats fonts properly. After running fc-cache Scribus worked perfectly.


It sounds very much like an error in Qt/KDE and should certainly report it:



Otherwise, nothing you try is going to help if the Qt font indexer has a problem with this font. Make sure to include details and steps to reproduce.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.