I'm using ubuntu 12.10 with the kernel 3.7.0-7 from xorg-edgers fresh X crack. Now when I try to launch wmware workstation it asks for linux header path like shown here. I tried all the solutions on that page but nothing works... It was working before I switched to the 3.7 kernel. Any idea what I can do to get it work?

6 Answers 6


To make the original answer a little clearer for other folks:

In Ubuntu 13.04 (should work in 12.10 as well), with just the kernel headers installed, you can do this:

sudo ln -s /usr/src/linux-headers-$(uname -r)/include/generated/uapi/linux/version.h /usr/src/linux-headers-$(uname -r)/include/linux/version.h

I have to do that every time I update the kernel right now.

  • Work like a charm. THX!!
    – przemo_li
    Mar 19, 2013 at 8:52
  • I have Ubuntu 12.04, and installed kernel 3.8 and it worked for me too. Jun 8, 2013 at 2:42
  • This command got me past vmware not finding the headers. However now when I click 'install' to start the kernel modules installing it just silently crashes, log file contains no errors. Ubuntu 13.04
    – Halsafar
    Jul 11, 2013 at 21:23
  • This is what worked for me.
    – Naveen
    Dec 1, 2014 at 5:33

First thing to check is for the availability of a newer version of VMplayer or workstation to download. If the latest version does not work, then start looking at the error messages and try to add a link to fix the problem.

Looks like the version.h file got moved again, so adding a symlink is needed:

ln -s /usr/src/linux-3.7-rc6/include/generated/uapi/linux/version.h /usr/src/linux-3.7-rc6/include/linux/version.h

See the link http://rglinuxtech.com/2012/11/18/vmware-9-0-1-not-so-clever-after-all/ The headers have been a moving target since 3.2, and vmware does not keep up.


After making sure the proper Linux header files were installed for my kernel, manually creating symbolic links, installing build-essential, and basically following all advice that you linked to here, I still was receiving an error saying the path to the linux headers were invalid.

After doing a sudo apt-get update, it turns out there was a newer version of the Linux headers available than was previously reported. Upgrading the currently installed headers package to the latest version fixed the problem, and the VMWare Config Tool was able to find the headers. In my case, the packages which needed to be upgraded were linux-headers-generic-pae and linux-generic-pae.


If following the instruction that VMware gives you in the error messages doesn't work, you might have to re-install VMware.

I have the same problem with VirtualBox PUEL every time the kernel is updated because I installed it manually from the .deb files. Fortunately the VBox error message includes instruction for re-running the installation script to install the right code into the kernel.

I surmise that if you use a PPA it might get around this problem by including it in the kernel each time it is updated, but I haven't tried it yet.


In my case, the symlink to version.h didn't work. I found that this helped on a 64-bit 13.04 system:


The headers package was already installed, but what seemed to make the difference was installing 'build-essential'. I then uninstalled vmplayer (running the installer with -u vmware-player does this) and reinstalled, and everything was copacetic after that.

  • Also, VMWare version should be fresh, because it depends on kernel headers.
    – Danatela
    Jul 23, 2013 at 2:40

I have found that with Ubuntu 14.04 the solution is very simple:

In the terminal:

sudo apt-get install build-essential linux-headers-$(uname -r)

Now run VmWare again and it will ask to rebuild and run perfectly. I do not think Smeghead needed to reinstall.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.