So I wanted to play around with CHrome OS, and installed the Vanilla version of Chromium OS to my trusty USB Stick. I used the Win32DiskImager.exe to install the OS to the USB stick. All went well, but I decided I didn't really want to use the OS, so I formatted the USB Stick in WIndows using the Minitool Partition WIzard. I finished with that and downloaded openSUSE, and then installed it with your normal Linux Live USB Creator.

That's when everything got screwy. It wouldn't boot after that. Files could be copied to the stick, but it's not bootable anymore. I tried unetbootin after that with the same result, and then one last time with the generic live usb creator from linuxpendrive.com.

Any idea what could have happened? Was it the win32diskimager that toasted the usb stick?

And is there any way to get back to a bootable state? I was thinking of booting into gparted and formatting from there to see what would happen if I formatted through Linux instead. (Oh, I should mention I tried a regular good 'ol format through Windows 7 as well.

Any help would be appreciated.


I have found that using:

fdisk /dev/sdX 

(where X is the identifier of the USB device in question - make SURE this is correct!) and deleting the partition table:

  • p - to print (display) the partition table
  • d - to delete (gives choice of partition if more than one)
  • w - to write the changes

...seems to work on rebooting. If that doesn't work, zero-filling the USB stick then re-imaging it (and possibly deleting the partition table as per the above) might work.

To do this:

dd if=/dev/zero of=/dev/sdX

BE WARNED that chosing the wrong device as X will destroy the data on it.


Was your old flash drive bootable before and I had the same problem with win32image writer I used hp usb format tool and it worked pretty well try that to see if it works I am noob so don't know much

Also here is the link for hp format tool


Sorry to keep editing but for me I installed ubuntu right after hp formatting my flash drive so for me it worked

  • Yes, I've used it many times to boot when I want to try a different distro. I just formatted it through gparted. I removed the lba flag from the partition, and we'll see what happens now. If that doesn't work, I'll try your suggestion of the HP tool. Thanks a bunch. – Dana Dec 22 '12 at 18:03

Mainly it happens because of the installation of any OS that you perform in your machine.

After installing an OS, sometimes the BIOS reorder the boot priority order of the devices. Before installing OpenSUSE the order probably was: CD/DVD Drive > USB > HDD; after the installation it turned to be: HDD > CD/DVD Drive > USB. So at startup, your system veryfy the possiblity to boot from the HDD and if it is possible it won't try to boot from USBs and CDs/DVDs.

To restore the prior order you need to enter in BIOS (It may vary to computer to computer, but in general to enter in the BIOS you need to be pressing F1 or F2 or DEL or ESC or F10 at the startup time). In the BIOS go to the Boot tab and there you'll find an option to change Boot Order or Boot Priority or Boot Management or Boot Sequence, then just put the USB on the top of the list, CD/DVD Drive in second and HDD in third.

Done, now you should be able to boot from your USB Stick.

  • THe boot order didn't change. The Chrome OS was a live usb installation, so it wasn't dual booted, so it never changed the boot order. I'm using this on an old eeepc , and just use the <esc> key to get to the boot menu, and choose the USB stick. – Dana Dec 22 '12 at 18:14
  • Oh, sorry for my misundertanding, so I think that Goku (lovely name) answer should solve your problem. – Rodrigo Martins Dec 22 '12 at 18:16
  • Not a problem! I'm currently formatting the stick with HP utility, because the formatting through gparted didn't do anything. I'll post back when the formatting completes. – Dana Dec 22 '12 at 18:29
  • I had thought I posted the solution, but I guess I didn't. It turns out that the Chromium OS Vanilla nightly builds creates a bunch of tiny partitions on a USB Stick, and I don't know why. Gparted didn't fix it, nor any Windows Partition Managers. The HP USB Stick Formatting Tool DID fix it though. – Dana Jan 21 '13 at 16:08
  • edit Now, after formatting using the HP Formatter, I can use any Windows based partition editor and reformat the stick and it will work properly. Don't know why, don't really care. I now format all my USB sticks FIRST, with the HP Formatter, and all is well after that. I'd love an explanation from HP on that one. – Dana Jan 21 '13 at 16:09

It happens when usb drive lose its Partition Table. To recover it you can just use Gparted in virtual machine or live usb or any other way. Just run Gparted, then select your usb drive, then from Device option select Create Partition Table and proceed. [Cautoin: This will remove all data from the drive].


I had the exact problem you described, tried out Chrome OS with win32diskimager on 2 different usb drives and both then had problems booting afterwards (as well as their partitions being scattered, but repaired using minitools partition wizard).

I then used gparted on a 3rd usb to Create Partition Table on the 2 faulty ones and that has cleared up the problems and the usb drives now boot perfectly!

Took me ages to find this answer so thanks MARUF SARKER!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.