Here's my weird problem, with a UEFI Ubuntu 12.10 64 bits installation on an Inspiron 14z ultrabook with an integrated Atheros AR8162 ethernet card (NIC).

If the AR8162 card is enabled in BIOS, Ubuntu won't load, as it will hang in a blank purple screen or, in recovery mode, at "loading initial ramdisk". If the AR8162 card is disabled, it will boot just fine. The problem is that I need an ethernet connection...

What is strange is that I'm able to boot Ubuntu in legacy mode with the AR8162 enabled in BIOS and this card is working just fine with the alx module available in compat-wireless package (see: 12.04 does not detect eth0(Atheros AR8162 )). The only thing is that I want to keep dual booting with Win8, so UEFI Grub installation is mandatory.

Any idea someone on how to boot Ubuntu 12.10 in UEFI mode, with a working AR8162 card?



I'm not sure about the cause of the hang, but one workaround is to boot Ubuntu in BIOS/legacy mode and Windows in UEFI mode. This is awkward with most firmware implementations, but my rEFInd boot manager can help, since it can redirect the boot process from EFI-mode to BIOS/legacy-mode. To do this, you'd need to install rEFInd, add hdbios to the scanfor line in its refind.conf file, and install the BIOS version of GRUB (grub-pc in Ubuntu's packages). Thereafter, you should see rEFInd menu options when you start up for booting either Windows or a legacy OS, and the latter will take you to the BIOS-mode GRUB. Initially you'll also have additional menu items that will launch the EFI version of GRUB and perhaps directly launch Linux kernels in EFI mode, but you can eliminate those by removing the EFI-mode GRUB's boot loader on the ESP and by removing the ext4fs driver that rEFInd's installer will set up (or by setting it up without the file to begin with). OTOH, there's a slim chance that booting in EFI mode via a rEFInd->kernel path (without involving GRUB) will fix the problem, so it may be worth trying that before you even install grub-pc.

Another option is to convert from a GUID Partition Table (GPT) disk setup to a Master Boot Record (MBR) setup and boot both Windows and Ubuntu in BIOS mode. This will involve more work, though, since you'll need to convert the partition table type (which is possible with gdisk) and install appropriate BIOS-mode boot loaders for both OSes. I've seen instructions on doing this for Windows, but I don't happen to have any URLs handy.

Of course, it's probably better to get the computer to boot Linux in EFI mode without hanging, so if somebody has a fix for that, you should try it first.

  • Thanks Rod. Your suggestion may be my B plan, but for now, I'm still looking for a solution to be able to boot in EFI mode, with a functional NIC. Dec 23 '12 at 17:35
  • In lieu of any better suggestions, try doing a direct rEFInd->kernel boot path, bypassing GRUB. This isn't very likely to work, but there's a chance that something about the way GRUB is launching the kernel in EFI mode is causing it to fail, and that relying on the EFI stub loader instead will work.
    – Rod Smith
    Dec 23 '12 at 23:32
  • I've tried your suggestion of doing a direct rEFInd->kernel boot, but I still get the same problem. Thanks anyway, I appreciate your input. Have a nice Xmas! Dec 24 '12 at 14:09
  • I'm having this exact same issue on the exact same hardware, though I'm using Arch Linux not Ubuntu which makes me fear it's an issue with the kernel. Also, this problem doesn't seem to be widespread in the slightest (this exact laptop being the only machine I've heard of this happening to) so we may never get a fix. If only I were a Linux Kernel aficionado and could fix it myself! Edit: I stand corrected; there's other cases of this, apparently, with different laptops but similar Atheros cards.
    – Brandon
    Jul 22 '13 at 0:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.