Every time I want to open Software Center to install something, my computer hangs before it starts. What could be the problem?


When I try sudo apt-get update and type my password, in the end of that I get error:

W: GPG error: http://repo.steampowered.com precise InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F24AEA9FB05498B7


When I run software-center command from terminal, it does not give any errors, only thing it writes in output is:

Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
2012-12-23 15:55:18,554 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2012-12-23 15:55:19,000 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True

and after that it stays that way...


there is a all time default solution which I am following if I saw any thing like that .

open your terminal sudo rm -rf /var/lib/apt/lists/*

paste the above line . try again .

|improve this answer|||||
  • ok, now trying .. – hingev Dec 22 '12 at 7:21
  • sorry, but problem still be continuing.. – hingev Dec 22 '12 at 7:29

It looks like you have installed steam without importing the key. Run the following commands:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys F24AEA9FB05498B7
sudo apt-get update

It will import the key for the steam repository. Now you can open the Software Center again.

|improve this answer|||||
  • hm.. no, it imported key, but still can't open software center :( p.s. now sudo apt-get update haven't gived any errors – hingev Dec 23 '12 at 7:23
  • Does Software Center give any errors when you run it by typing 'software-center' in a terminal? – Zilvador Dec 23 '12 at 10:21
  • I made edit, could you look at that please. – hingev Dec 23 '12 at 11:59
  • Hmm... try 'sudo apt-get --reinstall install software-center' – Zilvador Dec 23 '12 at 13:19
  • i reinstalled it, and now when i run it from terminal, computer still works, but nothing changes. it writes output in edit, and stays that way. :( – hingev Dec 23 '12 at 14:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.