The issue:

I can ping all devices on the network except the gateway ( and in turn can not access outside of the network without proxying through another device.

The system:

Lenovo x230 Tablet with a Realtek wifi adapter running on Quantal:

Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)

The wtf:

I can obtain an IP from the router

wlan0 Link encap:Ethernet HWaddr e0:06:e6:c2:d2:e0
inet addr: Bcast: Mask:
inet6 addr: fe80::e206:e6ff:fec2:d2e0/64 Scope:Link
RX packets:178844 errors:0 dropped:0 overruns:0 frame:0
TX packets:101517 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:121465876 (121.4 MB) TX bytes:10612848 (10.6 MB)

I can ping other devices:

➜ ~ ping
PING ( 56(84) bytes of data.
64 bytes from icmp_req=1 ttl=64 time=3.84 ms
64 bytes from icmp_req=2 ttl=64 time=1.32 ms

I can not ping the gateway:

➜ ~ ping
PING ( 56(84) bytes of data.
From icmp_seq=1 Destination Host Unreachable
From icmp_seq=2 Destination Host Unreachable

My resolv.conf is autogenerated with:

➜ ~ cat /etc/resolv.conf

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
search nc.rr.com

My /etc/hosts:

➜ ~ cat /etc/hosts localhost quantal

My routing table:

➜ ~ route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default UG 0 0 0 wlan0
link-local * U 1000 0 0 wlan0 * U 9 0 0 wlan0

Lastly, my module info for device:

➜ ~ modinfo rtl8192ce
filename: /lib/modules/3.5.0-17-generic/kernel/drivers/net/wireless/rtlwifi/rtl8192ce/rtl8192ce.ko
firmware: rtlwifi/rtl8192cfw.bin
description: Realtek 8192C/8188C 802.11n PCI wireless
license: GPL
author: Larry Finger <Larry.Finger@lwfinger.net>
author: Realtek WlanFAE <wlanfae@realtek.com>
author: lizhaoming <chaoming_li@realsil.com.cn>
srcversion: DD4F3D83A75531AC98862F2
alias: pci:v000010ECd00008176sv*sd*bc*sc*i*
alias: pci:v000010ECd00008177sv*sd*bc*sc*i*
alias: pci:v000010ECd00008178sv*sd*bc*sc*i*
alias: pci:v000010ECd00008191sv*sd*bc*sc*i*
depends: rtlwifi,mac80211
vermagic: 3.5.0-17-generic SMP mod_unload modversions
parm: swlps:bool
parm: swenc:using hardware crypto (default 0 [hardware])
parm: ips:using no link power save (default 1 is open)
parm: fwlps:using linked fw control power save (default 1 is open)

Things I've attempted:

Turning off fwlps, ips. Attempted to compile a driver from upstream(realtek.com) and even tried the latest daily mainline kernel for Quantal. Also tried latest compat-wireless and switching out firmware. Tested Windows 7 and verified the card worked. Tested slackware 14, Fedora, Arch and they all exhibit the same issue.

Has anyone seen this before? What really baffles me is that I can not ping the gateway. To verify I can ping the gateway from another system:

λ ~ → ping
PING ( 56(84) bytes of data.
64 bytes from icmp_req=1 ttl=64 time=1.35 ms
64 bytes from icmp_req=2 ttl=64 time=1.22 ms
64 bytes from icmp_req=3 ttl=64 time=5.11 ms

This also doesn't happen outside of my network as I was able to use this laptop at UDS-R which kind of points to a router issue but anything without a Realtek adapter works :\

I dont know if any Realtek developers monitor this site but has anyone run into an issue like this?

Thanks Adam


For anyone interested, the relevant bug report is:


@Adam: I have the same setup as you (an X230 with the realtek adapter) and following these instructions fixed the issue:


I am on Ubuntu 12.04 with 3.2.0-35-generic.

  • No luck unfortunately. When i strace a ping it returns a MSG_NOSIGNAL even though i can ping other devices on the network. Dec 26 '12 at 23:53

For me changing router to form 802.11bgn to 802.11bg` solved the problem. Answer found here: https://askubuntu.com/a/483040/12325

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.