Yesterday, I updated my Ubuntu 12.04 to the Kernel 3.5.0-21 and the wireless card stop working... In other threads I saw the same problem with another kernels. Anyone have the new driver? I sent a mail to Realtek but I have not received an answer yet...

The model is: Realtek RTL8723AE Wireless LAN 802.11n PCI-E NIC



I assume you installed the driver by downloading and compiling the Realtek package. When a new kernel is installed by Update Manager, you must recompile:

cd Desktop/RT8723  <--or wherever you compiled the package
sudo su
make clean
make install
modprobe rtl8723e

Oops! It errors for me, too. You might try this package: http://www.kernel.org/pub/linux/kernel/projects/backports/2012/12/04/compat-drivers-2012-12-04.tar.gz

./scripts/driver select rtlwifi
sudo make install
sudo modprobe rtl8723ae

You 'make clean' because the module was compiled originally against your specific versions of kernel, headers, gcc, etc. When updates are installed, the various files built in the compile process may or may not work correctly with, for instance, a newer gcc version, so wipe it all out and start fresh: make clean.

| improve this answer | |
  • Hi, I tried to recompile the package, but it doesn't work anymore. I think that I need another driver, for 3.5.0-21 version. Before the update I had 3.5.0-19... Why do you do "make clean" before recompile? Thanks – moro Dec 21 '12 at 19:32
  • Sorry, but It didn't work :( I tried installing the driver in the others kernels (I have 3.5.0-17, 19 and 21) and nothing... any ideas? – moro Dec 22 '12 at 2:16
  • Let's see: lspci -nn | grep 0280. We wonder if the driver covers your device. Is your device 10ec:8723? – chili555 Dec 22 '12 at 2:50
  • The command gave me this: 02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:8723] – moro Dec 22 '12 at 3:57
  • When you sudo modprobe rtl8723e, are there any errors or warnings? Any clues in dmesg | grep rtl? Is the wireless switch on or off: rfkill list all? Is a wireless interface wlan0 created: iwconfig? – chili555 Dec 22 '12 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.