(Sorry if some of this info is irrelevant, not sure if how much of this will matter or not)

So I was reinstalling Ubuntu 12.10 with the same USB I had used to install it the first time (dual boot with win7). I initially had a grub error booting into windows (but not ubuntu), but I could still boot into windows by switching to the windows bootloader in the BIOS. So I ran boot repair in ubuntu and everything was fine. However there were some sound issues, I tinkered with alsa and ended up breaking it more, so I decided to reinstall. When I booted from the USB, I got the option to remove the existing ubuntu and reinstall (which I figured would leave windows alone, since there were other options for that and this option specifically mentioned only Ubuntu files). Now, when I try booting from anything besides the USB, I get the grub2 error: unknown filesystem and it goes straight to the recovery command line.

If I could just get windows to boot I could wipe everything besides windows and start over from there, but the windows bootloader now goes straight to grub, where before it still at least booted just windows. My problem is all I can do (besides the grub2 reovery command line) is off the live USB, so I don't think I can install anything (like boot repair) and I can't view my actual hard drive partitions from the ubuntu terminal, as it just lists the USB. I have no clue what to do from here, short of a total wipe of the HDD when installing ubuntu, which will only be a last resort for me.


Okay, talk about crazy. I tried another reinstall, this time doing the custom selection for choosing which partition to install to. Still no luck. Tried it a 3rd time, this time choosing a different boot option from the BIOS for the USB(there were 2 options for booting from the USB, one with UEFI in the name). Reinstalled again, once again choosing the manual selection for choosing the partition to install to. On this attempt, everything works great. Including all the sound problems I was initially having which prompted the reinstall. Just have to run boot repair again, as the windows option isn't booting in grub. Just leaves me thinking, what the hell...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.