I tried installing Golly from the package manager. Everything seems to work fine, except that almost all the menu options are greyed out, disabled and unclickable. I tried with the latest version from Sourceforge and have the same issue.

Only the "Preferences", "Quit" and all the "Help" menu options are not greyed out. This problem only seems to affect Golly. I found an old bug report, which seemed to be a more specific version of this problem, but that is closed and two years old...

My question is: what can I do to diagnose the problem? No other program seems to have this issue. No one else seems to have noticed this issue. What can I try to work out what has broken?

I am running 12.04. The problem occurs with the version of golly in the repos and with the latest version downloaded from sourceforge.

  • It may or may not be relevant - what version of ubuntu are you using. The bug report mentions wx libraries - are you using stock, or newer/older versions for example a PPA? – fossfreedom Dec 24 '12 at 11:24
  • As for wx libraries, I guess I'm using the stock ones? I'm not even sure how to check that... – Seamus Dec 24 '12 at 20:30

golly doesn't appear to support the global menu so start it without. To test this - from a terminal use -


To adjust golly's .desktop for starting from application menu/Dash or launcher icon -

 gksudo gedit /usr/share/applications/golly.desktop

Edit the Exec= line to this, save

Exec=env UBUNTU_MENUPROXY=0 golly

If you wish to protect the .desktop from an update (unlikely), then copy the .desktop to your Home folder instead & edit as above. (may need to log out/in to take affect, usually doesn't

mkdir -p ~/.local/share/applications && \
cp /usr/share/applications/golly.desktop ~/.local/share/applications && \
gedit ~/.local/share/applications/golly.desktop
  • Excellent thanks. Do you think I should file a bug report with golly about this? What specific information do you think I should include? – Seamus Dec 24 '12 at 22:36
  • 1
    no reason not to file one, just note that for the most part the menus are non-functional when in the unity panel, (global menu), but work when returned to app window. – doug Dec 25 '12 at 0:47
  • 1
    or add alias golly="env UBUNTU_MENUPROXY=0 golly" to your ~/.bashrc – Ciro Santilli 新疆改造中心996ICU六四事件 Feb 1 '13 at 16:13
  • @Seamus Or file a bug with Unity? – nealmcb Aug 30 '14 at 20:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.