I have a Netgear WNA1100 usb wifi adapter. I have installed Atheros driver from Forum Details (btw name of the file is ath9k_htc-installer.1.0.1-maverick-fixed.deb).

I wish to make a setup like connectify(windows) on ubuntu, so that I can connect my phone wirelessly to my laptop via Netgear WNA1100 (behaving as AP) and eventually use internet via my wired lan.

I have installed the above mentioned driver, hostapd and hostap-utils. Following is my hostapd.conf file.

interface=wlan1 # The interface name of the card
driver=ath9k_htc # The card driver
ieee80211x=1 # Use 802.1X authentication

When i run

sudo hostapd /etc/hostapd/hostapd.conf

I get an error

invalid/unknown driver 'ath9k_htc # The card driver

I think the driver is installed fine, as i can see the blue led blinking on the netgear adapter, which was not blinking earlier.

  • Can someone please guide me how to achieve this setup?
  • I will appreciate an example hostapd.conf file with a simple wpa_psk security setup.
  • Please be detailed and descriptive with commands. How to run and end it.

Following is output from lsmod, i have only pasted the entries which had ath and ath related info. Which driver shall i use.

Module                  Size  Used by   
ath9k_htc              42903  0 
ath9k_common            2563  1   ath9k_htc   
ath9k_hw              285176  2 ath9k_htc,ath9k_common   
ath                    13001  2 ath9k_htc,ath9k_hw
cfg80211              139811  3 ath9k_htc,mac80211,ath
compat                  4020  1 cfg80211   
led_class               2633  3 ath9k_htc,thinkpad_acpi,sdhci


  • Which is the driver that i have to use? Jan 25 '11 at 4:31
  • How do i uninstall it. Jan 26 '11 at 9:44

I just had a review of the ath9k_htc deb installer you've pointed to, it's not a supported driver. Worse the installer is all over the place with debian errors, inconsistencies and a couple of security issues. It worries me that users and being recommended to install this package at all.

Check what kernel driver is currently loaded by using lsmod, if you can find ath9k or ath9k_htc in the list, then that's what it's called. Use that exactly name. If that still doesn't work, then it's very likely that because the htc is a non-standard driver, the hostapd just don't know how to deal with it.

But I think it's probably more likely that the driver is really the ath9k driver with new firmware.

  • I have used all relevant names I see in lsmod (ath9k_htc, ath9k_hw,ath, cfg). Attaching lsmod output. Jan 25 '11 at 3:49
  • Then I'm sorry, but that driver, installed in that way, isn't supported by hostapd. My guess is that there are files that need to be found in certain places and the deb file doesn't put things in the right place. If you can find a DKMS driver for ath9k_htc, that might work better. Jan 25 '11 at 3:59

If you read the sample hostapd.conf file, "ath9k_htc" is not a valid driver name for hostapd. You cannot just put anything after "driver=". Read the sample hostapd.conf, there you will find the valid driver names that you can use.

Additionally, AP functionality for the ath9k_htc is provided as a patch and is experimental (very fresh), besides you need new firmware, which means: downloading compat-wireless, applying the patch, compiling and installing. I don't think that .deb installer has AP functionality.

I invite you to visit wireless.kernel.org for more information.


Like user10699 said, "ath9k_htc" is not a valid driver option for hostapd.conf. You want to use "nl80211" instead. The driver option for hostapd is more about how to communicate with the kernel module, versus what the underlying driver actually is.

A couple other things to check:

  • Make sure you're running kernel/compat wireless 3.0 or greater. AP mode for ath9k_htc was added then (and is still considered experimental).
  • Check what firmware you have. It should be htc_9271.fw (found here once kernel.org is brought back up).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.