I was listening to music, and my sound suddenly went dead in all my applications. I'm using Ubuntu 12.04, which uses pulseaudio, so I tried sudo /etc/init.d/pulseaudio restart, but nothing happened. According to lsof | grep pcm, nothing is using the soundcard at the moment, although I'm not entirely sure if my source for that command is applicable.

Is there a way another way to restart Ubuntu 12.04's sound system from the command line without rebooting the system?

  • 1
    This answer worked for me. askubuntu.com/questions/15223/… – rickfoosusa Aug 25 '14 at 23:58
  • I think the solution really depends on the computer you have and the ubuntu version installed on it. For me none of the 2 top answers worked. joeytwiddle's answer worked. I have a Lenovo Legion Y520 with Ubuntu 16.04: sudo pm-suspend is the only thing that worked for me. – Yoann Pageaud Sep 3 '19 at 13:05
  • This is NOT an answer to the question, however, this page show up in the top when searching for how to fix the sound in Ubuntu 18 and 19. When having trouble with the motherboard built-in Intel soundcard, this solution has worked for me: linuxuprising.com/2018/06/… Excerpt: Ubuntu 18: add "options snd-hda-intel model=generic" at the end of the /etc/modprobe.d/alsa-base.conf reboot Ubuntu 18, 19, 20. Kernel 5.3.0-41 and -42: Edit /etc/modprobe.d/alsa-base.conf as root and add "options snd-hda-intel dmic_detect=0" Edit /etc/modprobe.d/blacklist.c – thomasa88 May 16 '20 at 15:07

I've used pulseaudio -k && sudo alsa force-reload a couple of times, and it worked well. The first part kills pulseaudio, the second reloads ALSA. You don't need to restart pulseaudio, because it auto-restarts.

  • 17
    This helped to me to fix the issue 'no sound after suspend' I have suffered from for don't remember how long. – khustochka Aug 31 '13 at 19:19
  • 2
    Sometimes you might need to clear pulse config with "rm -R ~/.pulse*" before issuing any restart. – Radu Maris Sep 23 '14 at 11:33
  • 1
    It works for me after my USB headphone stop to work. – Felipe Oct 20 '14 at 22:47
  • 6
    pulseaudio -k saved my life ! no sudo needed – Aitch Apr 10 '18 at 21:15
  • 5
    still work in 18.04 – Fat Mind Jan 29 '19 at 18:34

What I do when my sound doesn't work is

killall pulseaudio

and then I press Alt + F2 and type in pulseaudio. It usually works for me.


Just for completeness, in newer Ubuntus versions that use systemd, I used this and it worked well:

systemctl --user restart pulseaudio

  • 4
    this answer fixed my problem – Marlon Jun 21 '20 at 17:23
  • 1
    So clean, love it! ✨ – pkoch Jul 4 '20 at 14:12
  • 3
    This is the way to restart PulseAudio in Ubuntu 20. Thank you! – kas Nov 1 '20 at 19:43
  • 1
    This, along with killing/restarting Alsa, allowed me to get the audio working on my Acer Swift 3 (Ryzen 4700U) under Kubuntu 20.10. – Pockets Nov 12 '20 at 4:46
  • This answer is very useful since pulseaudio won't function properly after a session change (or CTRL-ALT-BACKSPACE) in ubuntu 20.04 – JB. With Monica. Jun 3 at 14:13

In my case there were nasty messages in kern.log / dmesg:

sound hdaudioC0D2: HDMI: invalid ELD buf size -1

The solution was simply to suspend and resume the machine!

$ sudo pm-suspend
  • 2
    i don't know what was going on, I also had a mike problem, reinstalled pulseaudio and alsa packages, but the sudo pm-suspend trick did it.... – vlad-ardelean Aug 11 '16 at 10:33
  • 2
    Battery died on my Dell, did all the above, tried this as a last resort and it worked! Thanks! – iLikeBreakfast Jan 9 '17 at 5:33
  • 1
    Same thing happened here - after battery died, headphones did not work after next boot. pm-suspend fixed it. – axel22 Aug 24 '17 at 16:29
  • 1
    In the last Wifislax(64 2.0)livecd -intoram. The 'mixer' dissapeared and OS sound got muted after all I've tryed all above none worked only this. – Tyþë-Ø Feb 11 '19 at 10:02
  • 4
    Does someone able to explain this behaiour? – 18augst Mar 12 '19 at 22:07

Have you looked inside the folder to see if pulseaudio was available in init.d, try replacing pulse audio with alsa-utils


I had exactly the same symptom: sound suddenly died (after trying to use Audacity, in my case). The OP didn't mention he was/wasn't wearing headphones, which was my case. I tried all options here and, when going to Preferences and changing to HDMI or Speaker output worked, but switching to Headphones didn't work (no sound). I then tried to unplug and re-plug the headphones and it worked.


I encountered this issue with a USB audio device that would sometimes when booting the machine, not connect properly leaving me without audio until a reboot. If you are someone who is having the same issue but with a USB audio device then I recommend the following which fixed it for me:

sudo rmmod xhci_pci && sudo rmmod xhci_hcd && sudo modprobe xhci_pci xhci_hcd

None of the other answers would fix it and I assume that came down to the USB device not registering properly on boot. This simply reboots the USB devices. Note: you should only run all commands at once, running sudo rmmod xhci_hcd alone will disable all USB devices e.g., your keyboard, meaning the remaining commands cannot be run.

I will be honest and say that I doubt that the xchi_pci part is necessary, so if someone is more knowledgeable regarding this please correct me.


Sleeping + waking up the PC is the only thing that's fixed it for me (other than a reboot). I'm using bluetooth audio w/ the notoriously buggy intel ax20x.


FINALLY! This worked for me, and has worked repeatedly: https://askubuntu.com/a/221922

"Go in to the Preferences and switch the Output Module to ALSA audio output. Quit VLC & relaunch. It worked ok to me"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.