I have just installed Xubuntu on a pretty old (12 years of age) PC and I am struggling to install the correct drivers for the GPU NVIDIA GeForce4 MX 420...

I have managed to get "additional drivers" but the app does not show in the menu, I went through a few procedures which ended up in my screen going no higher than 640x480, and tried all the sudo apt-get variations with nvidia-current and current updates...

I think I got the right version of the drivers ( 93.43.07 ) but they won't install from terminal as they say I am running an X server. So I shut the xserver but then I try and install them from terminal but after I write the exact same command

sudo home/username/Downloads/NVIDIA-Linux-x86-96.43.07.pkg1.run

nothing happens and the terminal says something like command not found.

. There are lots of similar topics on installing nvidia drivers but I seem to understand that current drivers are no good for my old GPU. Any help would be GREATLY appreciated! :)

  • Please remember that installing the Nvidia from the upstream source should be considered as a last resort. All cards should be supported by the packages provided by Ubuntu. Installing from the upstream source is harder, more complicated and might get you in trouble later (e.g. conflicts, upgrades, both this and a package can be installed, etc.) – gertvdijk Dec 29 '12 at 12:25
  • What was the ubuntu release you got this working with? – jarno Jan 2 '16 at 16:19

I just finished installing the latest Nvidia drivers and here's how I did it:

  1. Stop your Display Manager Service (I use Linux Mint 14, so my display manager is MDM - if you're running Ubuntu 12.10, then yours is LightDM): sudo service lightdm stop

  2. If it doesn't do it automatically, press CTRL + ALT + F1 to bring up the Terminal. Login with your username and password.

  3. Become root by entering the following command, followed by your password: sudo -i

  4. Navigate to the folder where your drivers are: cd/home/username/Downloads

  5. I took the liberty of looking up the latest drivers for you on the Nvidia website. Type this command to download the latest Nvidia drivers for Your GT 440: wget http://us.download.nvidia.com/XFree86/Linux-x86/310.19/NVIDIA-Linux-x86-310.19.run

  6. Run the installer: sh ./NVIDIA-Linux-x86-310.19.run

  7. Follow the installer. Please note that it may say that you have the nouveau driver installed. If that is the case, say yes to having the installer create a .conf file that will disable it. Reboot your machine to implement it.

  8. Repeat steps 1-5 to successfully install your drivers.

  9. Reboot after you're done.

| improve this answer | |
  • Hey James thanks a lot for your help and support! I actually wrote down the wrong GPU as going through your steps, as the installer started, I got the message The NVIDIA GeForce4 MX 420 GPU installed in this system is supported through the NVIDIA 96.43.xx legacy Linux graphics drivers. Please visit nvidia.com/object/unix.html for more information. The 310.19 NVIDIA Linux graphics driver will ignore this GPU. I will now make sure I got the correct 96.43 and will try your steps again substituting the installer, thank you – shaggyjack Dec 19 '12 at 23:34
  • It worked! After finding the correct version (96.43.23) and running into your step 7 as you predicted (disabling nouveau) I went through your steps again and now the driver is successfully installed! Cheers James :) – shaggyjack Dec 19 '12 at 23:48
  • @shaggyjack, someone says, it does not work with newer kernels, see here. Do you have the same experience? Which release of Xubuntu you are using? – jarno Dec 29 '15 at 11:46
  • As for step 8, I suppose you don't need to repeat step 5, but step 6, right? – jarno Jan 2 '16 at 15:14
  • I also applied this, but run into this issue. – jarno Jan 2 '16 at 16:20

IF you think you got the correct driver (the run file), do the following,

  • Press Alt+ctrl+F1, you will be drop to console login
  • Login using your id and password
  • execute sudo stop lightdm
  • execute cd Downloads/
  • execute chmod +x NVIDIA-Linux-x86-96.43.07.pkg1.run
  • execute ./NVIDIA-Linux-x86-96.43.07.pkg1.run
  • Follow the instruction, now it's pretty easy. You may need to reboot once and follow the steps again.
| improve this answer | |
  • Thank you so much for the quick reply, this has got me more far than I ever did! Although I just run into another problem, after entering NVIDIA Software installer I get the following error: ERROR: Unable to determine the version of the kernel sources located in '/lib/modules/3.5.0-21-generic/build'. Please make sure you have installed the kernel source files for your kernel and that they are properly configured; [..] If you know the correct kernel source files are installed, you may specify the kernel source path with the '--kernel-source-path' command line option. – shaggyjack Dec 19 '12 at 23:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.