I have just gotten my Ubuntu 12.04 LTS desktop computer reassembled after a trip back home and connected it to my parent's wireless Internet connection. The connection seems quite shaky (disconnects half the time, likely an ongoing issue with the wireless card I have installed), and it struggled to download updates because of the constant interruptions. Eventually, it managed to download the updated packages and started installing them. I got up and left it to do its work.

When I came back, I saw it was still having trouble staying connected to the wireless (no surprise there), but then I noticed that it seemed like Update Manager had stopped making progress on the installation. I opened the Details pane to see what it was last doing:

Where it stopped

My guess was that the installation script for flashplugin-installer couldn't complete the download until I stabilized the Internet connection. I hooked my Ubuntu laptop up to my desktop via Ethernet and shared its wireless connection using this guide, and as I am typing this now from my desktop you can see that the connection issue was successfully worked around.

However, even with a stable connection established, Update Manager seems "stuck" at its current position and won't go any further. It's not totally frozen, but I can't do anything beyond open/close the Details pane as the Cancel button is grayed out.

I know it can cause big problems if updates are stopped during installation, but I'm at a loss as to how this situation should be handled. I'm sure it should finish normally if I can just find a way to restart Update Manager, but the question is how this should be approached. How can I safely get my updates to finish installing?

  • I remember having a loooooots of problems with those flash updates. My solution was to install flash manually (grab it from a site, grab the library and add it to my Chrome/Firefox web browsers). Apart from that, I would suggest you, to update EVERYTHING besides Flash. After the updates are done, have fun hacking the Flash [;
    – Melon
    Dec 19, 2012 at 8:10

4 Answers 4


Ideally you should skip configuring flashplugin-installer and reconfigure it when you have a stable connection.

You can kill the download processs to proceed without configuring the package, mostly it is wget, or sometimes curl, but here it seems that it downloads via debconf.

To abort the transaction, you can kill dpkg,

sudo killall dpkg

Then remove the lock,

sudo rm /var/cache/apt/archives/lock
sudo rm /var/lib/dpkg/lock

Then when you have a stable connection, execute,

sudo apt-get -f install
sudo dpkg --configure -a
  • Thanks for the suggestion, but when I run the first command, I just get wget: no process found and it's still stuck. Any other ideas? Dec 19, 2012 at 9:02
  • I'm not sure what flashplugin-installer uses to download flash. May be try, sudo killall curl?
    – satya164
    Dec 19, 2012 at 9:06
  • Instead of sudo apt-get -f install I had to run sudo dpkg --configure -a
    – byf-ferdy
    Oct 19, 2013 at 12:19
  • if there's an error debconf: DbDriver ”config“: config.dat is locked by another process: Resource temporarily unavailable” while installing packages run sudo rm /var/cache/debconf/*.dat and then sudo apt-get -f install. Had the issue resolved this way.
    – R T
    Feb 1, 2016 at 7:41

Here's what I did.

First I found the stuck process (number 19123 in my case):

> pstree -p
│            ├─precise(9757)─┬dpkg(24158)─update-notifier(19121)─package-data-do(19123)
│            │               └{precise}(9759)

Then I helped out with bug report: https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/1243090 . By running "sudo gdb" then "attach 19123" and "bt" to create a backtrace. The backtrace helps the volunteers determine what's wrong.

Finally I used "sudo kill 19123" and received error message "Could not install 'update-notifier-common'" "subprocess installed post-installation script returned error exit status 143".

The rest of the install then completed without incident.


I recommend updating flash manually from the adobe website.You can un-check flash update option and try updating it again.

You can restart the update by doing the following:

open up terminal and run sudo apt-get update && sudo apt-get upgrade .It will download the necessary packages and continue your update.

sudo apt-get -f install should fix if there are any broken packages.

  • Just trying to run the first command returns this output. How would I safely stop the update in progress so I can try again? Dec 19, 2012 at 9:06

I've just had a similar freeze during upgrade. In my case it was dropbox-nautilus that it froze on, not flash, but the solution might be similar in both cases. In a terminal I did a ps -a to find out which processes were running, and found that dropbox-nautilus was in the list. Its process ID was 325, so I did sudo kill 325. That killed the dropbox-nautilus process, and the upgrade resumed. There was a popup error message stating that dropbox-nautilus had not been configured correctly and might be unusable after the upgrade, but I can worry about that later. At least the upgrade is proceeding now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .