For some reason, I can't get Gnome Shell working after installing fglrx. When I select Gnome Shell in the profile, it just goes to Gnome Classic (No effects).

A few other issues:

  • GDM has turned into something that looks a lot more fancy (not sure what it is)
  • Selecting System Default in the profile section just gives me a blank screen (not Unity)
  • When I drag a window around I get laggy windows-esque shadows

Oh and I'm on Ubuntu 12.10 with an AMD Radeon HD 6540 G2 graphics card

  • You should use xserver-xorg-video-radeon driver. It is open-source driver and far better then fglrx. – shantanu Dec 19 '12 at 4:31
  • @shantanu Gnome Shell works with that, but it messes up my screen resolution. The only way I've found to fix the screen res is by using fglrx. Any suggestions? – Chintan Parikh Dec 19 '12 at 4:48

Installing fglrx-updates and fglrx-amdcccle-updates fixed similar problem for me.

Don't forget to remove old fglrx first:

sudo apt-get purge fglrx*

then install

sudo apt-get install fglrx-updates fglrx-amdcccle-updates

and run

sudo aticonfig --initial

and reboot.

You should be able to run fglrxinfo and see output that confirms good installation.

  • No luck. fglrxinfo gave me: X Error of failed request: BadRequest (invalid request code or no such operation) Major opcode of failed request: 155 (ATIFGLEXTENSION) Minor opcode of failed request: 66 () Serial number of failed request: 13 Current serial number in output stream: 13 – Chintan Parikh Dec 19 '12 at 4:35

Fglrx is not fixed for ubuntu 12.10. It should breaks your graphics(only for 12.10). It's better to wait for fix.

Now to use open-source driver properly, follow the steps 1. Remove your existing fglrx driver

sudo apt-get purge fglrx*
  1. Open /etc/default/grub

    sudo gedit /etc/default/grub

  2. Replace the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" with


  3. Save and close the file and update your grub

    sudo update-grub

  4. Reboot. To check driver is working or not install mesa-utils

    sudo apt-get install mesa-utils

  5. Now go to system setting>Details or system info. Check on Graphics section. It should be Gallium

  • This broke my install I think. I rebooted and it gave me a black/purple screen, so I tried to reboot again holding down shift to do the nomodeset thing. No luck, for some reason holding down shift doesn't get me the GRUB menu. Any ideas? – Chintan Parikh Dec 19 '12 at 5:32
  • I know why it's messed up - instead of replacing the GRUB_CMD... line, I added radeon.modeset=1 to the end so it's "quiet splash nomodeset radeon.modeset=1". :/ Any ideas how to fix this? – Chintan Parikh Dec 19 '12 at 5:37
  • remove nomodset that's it. quiet splash is ok. – shantanu Dec 19 '12 at 5:38
  • Turns out nomodeset wasn't actually in it. I just got into an emergency shell and removed quiet splash, but still no luck :/ – Chintan Parikh Dec 19 '12 at 5:45
  • did you run update-grub and completely remove fglrx? Also remove xorg.conf from /etc/X11/ (sudo rm -rf /etc/X11/xorg.conf) – shantanu Dec 19 '12 at 6:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.