I recently update the system(12.10) on my laptop and after that whenever I plug the power cable in to my laptop it freezes and has no function of the mouse or the keyboard. I have to reboot the laptop and after that it's fully functional.(with the power cable plugged in.)

I need help to troubleshoot this problem or to report it as a bug if that is required.

  • 1
    It seems to me a bug related to kernel and acpi. I would try booting an older kernel first and see if the problem is related to a kernel update. – To Do Dec 18 '12 at 15:13
  • 1
    Try booting with the acpi=off option. In Grub press e and add it to the line containing quiet splash and report back. – To Do Dec 22 '12 at 9:10
  • 1
    Do you have Jupiter installed in your system? – Mukund Dec 30 '12 at 17:22
  • 2
    if you have it installed in your system i advise you to uninstall it. because even i had faced the same problem in 12.10..once i removed jupiter the problem was resolved – Mukund Dec 30 '12 at 17:32
  • 1
    @Mukund : Yeah I had Jupiter installed in my system and now I had removed it and my system works perfectly. No more freezing, So thanks a lot. Is this means I can't use Jupiter anymore? Is there any bug-fixed version of Jupiter.? Thanks again..! – Sudheera Jan 7 '13 at 3:52

Do you have Jupiter installed on your system?

If you do, I advise you to uninstall it. I faced the same problem in 12.10 but removing Jupiter fixed it.

Additionally, according to their official website, "Jupiter Applet has been retired and is no longer supported software." This might go some way to explain why it's now causing problems.

Note from a moderator: This answer was shown to fix things in the comments.:

@Mukund : Yeah I had Jupiter installed in my system and now I had removed it and my system works perfectly. No more freezing, So thanks a lot.

Please vote for it..

| improve this answer | |

This is a bug, and should be reported as one. If you find (or someone else reports) an effective workaround, that can be included in the bug report. As per the FAQ, bugs are off-topic on Ask Ubuntu, so the only part of this question that should really be addressed here is the issue of how to report this bug. Detailed work and troubleshooting on bugs in Ubuntu needs to happen on Launchpad; otherwise, valuable work tends to be ignored and fragmented.

Power management functionality is part of the kernel, so the correct way to report this bug is to run ubuntu-bug linux. Detailed technical information will be sent to Launchpad, but you will still have to describe the problem, including anything you've tried and what happened, in as much detail as possible.

One common mistake is to report power management bugs against the acpi package. That's not the right way, since the acpi package doesn't actually perform any power management; it's just an interface for getting information about the power management that is happening in the kernel (Linux).

I recommend that you:

  • Trigger the problem.
  • Record the time that you triggered it.
  • (Re)boot your Ubuntu system.
  • Once booted back up, immediately report the bug.
  • Indicate that you have done all this in your bug report, and specify the time (or approximate time) you triggered the freeze.

That may make it easier for triagers, developers, and other interested persons to identify entries in automatically attached log files that pertain to the problem.

It's a very good idea to read this thoroughly before reporting this or any other bug in Ubuntu. This question is also often quite helpful.

Finally, please note that if you are reporting this bug against the downstream kernel (linux in Ubuntu, reporting on Launchpad, as described here), you must be running (and you should have last produced the bug using) this version of the kernel, and not a custom-built or upstream kernel.org version.

If you report this bug or find it already reported, feel free to subscribe me to the bug if you wish.

| improve this answer | |
  • 1
    Thanks for this detailed reply, That's very kind of you. However I removed Jupiter from my system(as suggested by @Mukund), and then the system works fine. Do you think still I have to report this as a bug, because of course people will need to use Jupiter with Ubuntu without any problem. So what do you think..? thanks. – Sudheera Jan 7 '13 at 4:04
  • @Sudheera I don't think you are obligated to report this as a bug. But if you choose to do so, I think it would be helpful. (Search first--which is explained in the bug reporting resources linked to in my answer--to see if it's already been reported. If it has then you can subscribe and indicate you're affected, and, if you have any valuable information not present in the existing bug, comment with it.) I still recommend reporting the bug. BTW hopefully Mukund will post the solution as an answer soon so it can receive the bounty (as that appears to have solved the problem for you). – Eliah Kagan Jan 7 '13 at 4:14

I did this:

  1. Edit /etc/default/grub via a terminal.
  2. In the grub file, change GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to be GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor" Save the file.
  3. Then do sudo update-grub
  4. Close terminal
  5. Then go to Ubuntu Software Center
  6. search for 'pm-utils'
  7. click on 'more info'
  8. on the add-ons: uncheck 'Utility to control ATI Radeon backlight functions on laptops'
  9. click on 'apply changes'
  10. Close and RESTART!

Now it does not freeze when I plug/un-plug the AC power and it fixed the brightness buttons on my keyboard too. :)

  • Running Ubuntu 12.04 x86
  • Acer Aspire Laptop
  • Pentium B940 2.0GHz DC
  • 4GB DDR3 RAM
  • Intel HD Graphics (shows as Intel Sandybridge Mobile x86/mmx/SSE2

Hope this helps.

| improve this answer | |
  • Thanks for the reply, Can you explain how editing GRUB is related with the power problem? however I removed "Jupiter" and now my system works fine. thanks for replying... – Sudheera Jan 7 '13 at 4:07
  • Had the same problem again. Empirically, I noticed that I had inserted an SD card and had a GNOME extension to show and unmount removable media on the top panel. I turned off the extension, the problem went away. Seems to me that it is a problem with GNOME 3 and extensions/indicators on the top panel, since your problem was with jupiter (which is an extension or indicator program) and mine with this "Removable drive menu" extension. It has something to do with the battery indicator when you plug/unplug, as if it doesn't get along with other indicators/menus. Have to say I'm new to linux. – S.Maldini Jan 7 '13 at 4:38
  • I think your theory explains the situation. thanks. – Sudheera Jan 7 '13 at 7:33
  • I kept experiencing the problem until I did a kernel upgrade to 3.5.0-21. That fixed it for me and I have no AC adapter, battery or dim screen problems. – S.Maldini Jan 13 '13 at 4:53

I experienced the same problem on my laptop (Asus A53S; Ubuntu 12.10; Kernel 3.7.0).

I did two things:

  1. As Alvar indicated, I unchecked the 'Utility to control ATI Radeon backlight functions on laptops' functionality in pm-utils
  2. I updated my kernel to kernel 3.7.3, as this should fix the bug according to https://bugzilla.kernel.org/show_bug.cgi?id=51661. See Upgrade to Linux Kernel 3.7.3 for a manual on how to upgrade your kernel

Unfortunately I'm not sure which of the two methods did fix the issue, since I changed them both before going into reboot. However, unchecking a unnecessary feature in pm-utils is always a good idea, and updating to a new (stable) kernel too.

| improve this answer | |

its not a problem wit ubuntu some laptops tend to freeze when connected by power when charge is more than 75% restarting consumes power and it works fine agai to solve te problem just connect before starting there mightbe a bugfix from your BIOS

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.