I messed up the audio on my 10.10 installation. I had a problem of having no sound when plugging in the headphones and following many different solutions for that problem I (de)installed several packages. Now I have no sound at all.

I don't want a solution on how to fix my headphone problem. I just want to reset all audio-related setting and packages to the after-installation state (where at least the speakers were working).

I found several places where it is said that there is no global reset-to-after-installation possibility. Or that on could use apt-get clean, but even if this would remove all non-standard audio-packages, I don't know which packages I would have to install in order to get the standard audio-packages.


It may well be that in your case only a minor component of the sound system (mainly ALSA and pulseaudio) is missing that could be reinstalled or reconfigured easily. To tell this you should exactly know what you have done, what you have removed and what you may have installed as a replacement. From what you write in your question this unfortunately seems not to be the case.

What to do if we removed all or part of the sound system?

Restoring the sound system would in theory be possible by reinstalling all sound related packages including their default system wide settings, but to my experience a fresh install of Ubuntu is much faster, safer, and easier. Take care to keep your settings and data in your /home directory untouched. You may have to reinstall some additional packages but you will see that even these will have kept your individual settings from your untouched /home.

Is it only a wrong user setting?

If you only changed settings and configuration files but did not remove packages there may indeed be a good chance to recover your system. You can easily find out if your sound problems come from a wrong user setting or from system wide settings by looking at sound in the guest account or by creating a new user account. In case this new user has sound you will find all default settings in the new user's /home. In some cases wrong pulseaudio settings in a user's home can be removed by renaming/deleting ~/.config/pulse (~/.pulse in older releases).

mv ~/.config/pulse ~/.config/pulse.old

Of course this will not help when system-wide settings are broken.

  • I think your edit is related to my comment on JerryP's answer. When I wrote "playing with audio settings", I meant setting as well as packages; Installing/deleting/trying multiple combinations of packages and/or settings. I will however try if a new user has sound. – Pit Jan 24 '11 at 21:46
  • I tried with a new user but it did not work. Even though I hate to accept it, it seems there is not other possibility than a fresh install. – Pit Jan 25 '11 at 10:29
  • I have the same problem, but seriously? This is a dire state of affairs :( – digitalWestie Feb 2 '12 at 22:10
  • 3
    I managed to get my settings back deleting the .pulse settings folder - I'll def take more care to remember what I did in the future – digitalWestie Feb 3 '12 at 12:26
  • 1
    @digitalWestie - Thanks for your comment, its the only that worked for my with Ubuntu 12.04. I screwed up my audio messing around with Pulse equalizer....not a good idea BTW. – HDave Jun 21 '12 at 21:21

Synaptic has got a history function, but would probably take hours and hours to "undo" the changes. And wouldn’t be guaranteed that it works afterwards

  • This could actually work. I did not really do anything except playing around with those audio settings. I will see into that. – Pit Jan 24 '11 at 20:24
  • Nope; I used Synaptic, Software Center and Terminal (apt-get) to install/remove packages. I would have to combine the histories of all 3 which is simply not doable. Moreover not all packages installed/removed by dependencies are listed. – Pit Jan 25 '11 at 10:23

I used Ubuntu for about 3-4 years.

In my opinion, just try to login as root and open an audio/video file. Check headset now. If it works, just login to normal account again. It may be good. It worked for me twice. Sometimes my headset port has these difficulties. Try this.

  • 2
    Cargo-culting is not a good way to solve problems. Trying to properly understand what's going on is. – ulidtko Jan 8 '17 at 18:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.