23

I've searched everywhere in the system settings but I still can't find it.

2
  • I just found out that dconf has replaced gconf. Are you still looking for a fix?
    – Seth
    Jan 29, 2013 at 0:45
  • I will try that later. Jan 29, 2013 at 4:29

6 Answers 6

31

NOTE: I found out the Dconf has mostly replaced Gconf. Since using Gconf did't work, I have updated the instructions for Dconf.

You can change the setting in dconf-editor

sudo apt-get install dconf-editor

Open dconf-editor and navigate to: org -> gnome -> settings-daemon -> peripherals -> mouse then check/uncheck the 'locate pointer' option.

enter image description here

9
  • Didn't work... I have to admit, I did see that on my adventure through every system setting. Dec 18, 2012 at 3:04
  • 3
    It worked for me and I just add to it the comamndline way( to build in your scripts etc.): gsettings set org.gnome.settings-daemon.peripherals.mouse locate-pointer true. Great explanation in askubuntu.com/a/191013/79176 .
    – Huge
    Aug 24, 2014 at 17:10
  • 1
    This answer is not the best answer for newer versions than at least 15.10
    – MPi
    May 10, 2016 at 6:30
  • @MPi Did you try it? It works juts fine for me on 15.10.
    – Seth
    May 10, 2016 at 17:50
  • @Seth I did not try it, but it will surely work. My preference would always be a one-liner shell command with pre-installed tools, over a graphical step-by-step explanation with tools to be additionally installed. My comment about the Ubuntu version was probably wrong and misleading, though.
    – MPi
    May 11, 2016 at 7:33
16

In a terminal run:

gsettings set org.gnome.settings-daemon.peripherals.mouse locate-pointer true

to enable and/or

gsettings set org.gnome.settings-daemon.peripherals.mouse locate-pointer false

to disable.

9

Its under 'Mouse and Touchpad' in System Settings

enter image description here

12
  • What version of Ubuntu are you using?
    – Seth
    Dec 18, 2012 at 2:19
  • 12.10, here is a screenshot: i.imgur.com/nowzZ.png Dec 18, 2012 at 2:21
  • Looks like your running Kubuntu. Is that right?
    – Seth
    Dec 18, 2012 at 2:23
  • No, I'm using gnome 3.6 (with a custom theme, obviously). I think I may have discovered the cause, though. I updated to gnome-control-center 3.6, which doesn't have that option. Any workarounds? Dec 18, 2012 at 2:25
  • 1
    Yes, I've tried practically everything. Dec 18, 2012 at 3:52
3

You can do this using Gnome Tweak Tool ...

Look at "Keyboard and Mouse" settings ... its an On - OFF switch ... CTRL key.

3
  • 3
    -1 because of poor answer. Using GNOME Tweak Tool... in Ubuntu with Unity desktop? There is no "Keyboard and Mouse" settings in GNOME Tweak Tool.
    – user37165
    Dec 3, 2015 at 3:29
  • 1
    Still a useful answer, for Ubuntu users on 17.10 that switched to Gnome Shell: gnome-tweak-tools > "Keyboard and Mouse" > "Mouse" > "Pointer Location" / "Press the Ctrl key to highlight the pointer." Mar 6, 2018 at 8:58
  • 1
    its now become valid, and helped me, as i'm on ubuntu 18 - which uses gnome by defaultr
    – user230910
    May 30, 2018 at 5:01
1

In Ubuntu 20 this setting is in Settings -> Universal Access -> Locate Pointer.

With dconf

dconf write /org/gnome/desktop/interface/locate-pointer false
0

In Ubuntu 15.04 LTS

$ gsettings set org.gnome.settings-daemon.peripherals.mouse locate-pointer true

worked fine but I could no longer use the CTRL key in remmina VNC.

1
  • Don't you mean "gsettings set org.gnome.settings-daemon.peripherals.mouse locate-pointer false"
    – Jason
    May 21, 2018 at 17:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.