59

I have a server running Ubuntu 12.10 and need to be able to remote to this server without being logged-in.

I have found many solutions, but none seem to work with 12.10.

Can anyone give me step-by-step instructions on how to configure x11vnc to start as a service (prior to user login) so that when connecting with VNC I will be presented with a graphical login screen?

I'm new to Linux so please give as much detail as possible in your responses/comments.

Thanks

0

10 Answers 10

56

The above answers solve the problem, though a couple of amendments for versions of Ubuntu with systemd (15.04+), as follows:

  • Take advantage of new -auth guess functionality in x11vnc - which helps!
  • Update for systemd (not upstart)

Run the following to install:

sudo apt-get install x11vnc
sudo x11vnc -storepasswd yourVNCpasswordHERE /etc/x11vnc.pass
# for Ubuntu 15.04+
sudo nano /lib/systemd/system/x11vnc.service
# for Ubuntu 16.10+
sudo nano /etc/systemd/system/x11vnc.service

Insert this into the file:

[Unit]
Description="x11vnc"
Requires=display-manager.service
After=display-manager.service

[Service]
ExecStart=/usr/bin/x11vnc -xkb -noxrecord -noxfixes -noxdamage -display :0 -auth guess -rfbauth /etc/x11vnc.pass
ExecStop=/usr/bin/killall x11vnc
Restart=on-failure
Restart-sec=2

[Install]
WantedBy=multi-user.target

Then, start with:

sudo systemctl daemon-reload
sudo systemctl start x11vnc

And ensure the service starts on boot:

sudo systemctl enable x11vnc
10
  • 1
    Referenced bbs.archlinux.org/viewtopic.php?id=168756 for some advice on Requires/Afters params
    – babelmonk
    Sep 22 '15 at 9:48
  • 3
    why isn't this answer marked as the correct answer?
    – CybeX
    Jan 2 '17 at 11:19
  • 2
    If there is no display at all, then one may want to set arbitrary resolution: sudo xrandr --fb 1920x1080. Jul 26 '17 at 7:55
  • 3
    It is not a given the x11vnc will work immediately. It would be a good idea to provide a testing command before commiting to a service that restarts on failure every 2 seconds. I'm using lightdm and xfce4 on a headless cloud Ubuntu 17.10 server. Restart-sec should be RestartSec
    – Ray Foss
    Dec 21 '17 at 17:45
  • 3
    Ubuntu 18.04 also seems to want RestartSec rather than Restart-sec. Jul 7 '18 at 15:48
45

Install x11vnc:

sudo apt-get install x11vnc

Create a password for your user:

x11vnc -storepasswd

If you have ssh setup you can use it to start x11vnc assuming you are logged in already, but remember to tell it to use your password file:

x11vnc -usepw

If you are not logged in you will get an error with the explanation:

If NO ONE is logged into an X session yet, but there is a greeter login
program like "gdm", "kdm", "xdm", or "dtlogin" running, you will need
to find and use the raw display manager MIT-MAGIC-COOKIE file.
Some examples for various display managers:

 gdm:     -auth /var/gdm/:0.Xauth
          -auth /var/lib/gdm/:0.Xauth
 kdm:     -auth /var/lib/kdm/A:0-crWk72
          -auth /var/run/xauth/A:0-crWk72
 xdm:     -auth /var/lib/xdm/authdir/authfiles/A:0-XQvaJk
 dtlogin: -auth /var/dt/A:0-UgaaXa

Assuming you are using lightdm for the login you can fix this problem you can start x11vnc with the command:

sudo x11vnc -xkb -noxrecord -noxfixes -noxdamage -display :0 -auth /var/run/lightdm/root/:0 -usepw

I am not sure this is the best idea to run x11vnc as root. Maybe someone could edit with a way to access the login without using sudo.

Once this is running you should be able to connect using a vnc client such as krdc (for KDE). You might want to use GNU Screen to keep x11vnc running without needing the ssh session open

I was able to figure this out using http://ubuntuforums.org/showthread.php?t=2039022.

Here is a sample upstart job you can use to make it run at startup. It needs to be put in /etc/init/x11vnc.conf. (Note that newer versions of Ubuntu use systemd so see the other answer that has a sample systemd config):

# description "start and stop x11vnc"

description "x11vnc"

start on runlevel [2345]
stop on runlevel [^2345]

console log
#chdir /home/
#setuid 1000
#setgid 1000

respawn
respawn limit 20 5

exec x11vnc -xkb -noxrecord -noxfixes -noxdamage -display :0 -auth /var/run/lightdm/root/:0 -usepw

Once you have made this file you can start it by running: sudo start x11vnc You can check the log at: /var/log/upstart/x11vnc.log

9
  • 1
    You can run x11vnc as a normal user, no problem. For example: ssh to the host and run x11vnc -safer -forever -display :0 2>&1 & in a tmux session (good practice), it'll run under $USER.
    – Terry Wang
    Jul 17 '13 at 5:43
  • Also, just for reference, in order to change the viewport: superuser.com/questions/270608/…
    – Wtower
    Dec 19 '14 at 9:25
  • 2
    This doesn't explain how to have it auto start as requested (and is a common requirement for such a feature)
    – LovesTha
    Feb 25 '15 at 21:39
  • 1
    See here for a full list of x11vnc options. It took me a long time to find this: karlrunge.com/x11vnc/x11vnc_opts.html Sep 7 '16 at 1:55
  • 1
    And see here for an excellent tutorial on setting this up on a Raspberry Pi with auto-start at boot: megaleecher.net/Raspberry_Pi_VNC_Setup Sep 7 '16 at 1:56
15

Here's how:

  1. Install the X11VNC server (or through Ubuntu Software Center -> X11VNC Server)

    sudo apt-get install x11vnc
    
  2. Create a VNC password file.

    sudo x11vnc -storepasswd yourVNCpasswordHERE /etc/x11vnc.pass
    
  3. Create a job file in the editor nano (or gedit, leafpad etc.).

    sudo nano /etc/init/x11vnc.conf
    
  4. Paste this into the file:

    start on login-session-start
    
    script
    
    /usr/bin/x11vnc -xkb -forever -auth /var/run/lightdm/root/:0 -display :0 -rfbauth /etc/x11vnc.pass -rfbport 5900 -bg -o /var/log/x11vnc.log
    
    end script
    
  5. Save the file. You created a job for the Upstart event login-session-start.

  6. Restart Ubuntu.

That's it! You should now be able to connect with any VNC client even before login.

3
  • But how do you get it to work when lightdm doesn't create the auth file till a monitor is connected?
    – LovesTha
    Feb 25 '15 at 21:37
  • @didibus I've been trying to do this in Lubuntu, but x11vnc fails to autostart every time. It won't even start as a service, for that matter. File syntax is correct and I can start x11vnc from the shell just fine. What am I missing? Jun 21 '15 at 14:10
  • This works on Lubuntu too. Specifically, LeMaker's version of Lubuntu for the Banana Pi.
    – AaronD
    Mar 1 '16 at 21:05
3

babelmonks answer as a bash script, copy and save as x11vnc.sh & run with sudo bash /path/to/file/x11vnc.sh (sorry dont have enough rep to post a comment)

#!/bin/bash
#install x11vnc & set password
apt-get install x11vnc -y
x11vnc -storepasswd 123456 /etc/x11vnc.pass
#create config file for  system service
cat > /lib/systemd/system/x11vnc.service <<-EOF
[Unit]
Description="x11vnc"
Requires=display-manager.service
After=display-manager.service

[Service]
 ExecStart=/usr/bin/x11vnc -xkb -noxrecord -noxfixes -noxdamage -display :0 -auth guess -rfbauth /etc/x11vnc.pass
ExecStop=/usr/bin/killall x11vnc

[Install]
WantedBy=multi-user.target
EOF
#restart new services &  enable on boot
systemctl daemon-reload
systemctl start x11vnc
systemctl enable x11vnc
2
  • If you want to improve another answer, please suggest an edit to it and don't create a new answer. Jan 3 '16 at 9:31
  • Will happily add this to mine if you'd like to create an edit @nix-badweasel
    – babelmonk
    Jan 3 '17 at 13:36
2

Here is a config works for sddm (for KDE 5). Currently, -auth guess does not work for sddm, the auth file is different every time, so we need something like -auth /var/run/sddm/*. The service looks like,

[Unit]
Description="x11vnc"
After=multi-user.target

[Service]
ExecStart=/bin/sh -c "/usr/bin/x11vnc -xkb -noxrecord -display :0 -auth /var/run/sddm/* -rfbauth /etc/x11vnc.pass"
ExecStop=/usr/bin/killall x11vnc

[Install]
WantedBy=multi-user.target

I have to put it after multi-user.target, if after display-manager.service, x11vnc cannot find auth file, maybe sddm generates auth file later. This is tested on Manjaro 18.

1

Use my script for easy set up: installvncubuntu1604.sh

Usage:

chmod +x ./installvncubuntu1604.sh; sudo ./installvncubuntu1604.sh
0

I use my own shell: https://github.com/dvdvideo1234/UbuntuBatches/tree/master/x11VNC

start on login-session-start

script

sudo /usr/bin/x11vnc -xkb -auth /var/run/lightdm/root/:0 -noxrecord -noxfixes -noxdamage -rfbauth /var/srv/x11vnc/x11vnc.pass -forever -bg -rfbport <your_port> -o /var/srv/x11vnc/x11vnc.log

end script

into the file:

/etc/init/x11vnc.conf

It makes it auto-start on boot, even on the logon screen it asks for a password.

0

Install x11vnc package

#sudo apt-get install x11vnc

Then set the password

#x11vnc -usepw

Then create startup script for x11vnc

#sudo nano /etc/x11vnc.sh

In File:

/usr/bin/x11vnc -bg -forever -shared -reopen -usepw

Then save

#sudo chmod 777 /etc/x11vnc.sh

Then add the script file to Control Center=>Startup Application Then Click Add

> Name-----------x11vnc

> Command-----<map the script file

> Comment------service

This is must be required to add for all user

This will run after user login only

0

If you are working with Ubuntu 19.04, you can check it out with my answer as I figured it out.

babelmonk's answer almost solves my problem. But I got a problem with display manager ( to deal with login page). I'm using Ubuntu 19.04 in which gdm3 is used. And yet, even with 'smart' -guess parameter from x11vnc, I couldn't connect to my Ubuntu. Thus, I changed it to lightdm which works well.

You can change your display manager in this command:

sudo dpkg-reconfigure gdm3

BTW, if you wanna full steps to configure x11vnc, I wrote a full instruction.

0

An alternative to changing your display manager to fix this in Ubuntu 20 desktop or Ubuntu 21 Desktop is this script as a work around. On the default Ubuntu desktop installation, X11VNC does not work before logging in. This script automatically switches the Xauthority to use when logged in and when on the login screen even while using GDM3 as your display manager.

Plus, this one also auto configures X11VNC for you assuming that it's already installed.

It also runs X11VNC via tmux so you can see what is the issue after logging in incase you face issues.

#!/bin/bash


if [ -z "$1" ]; then echo "Please pass the password you would like to use as an argument to this script"; exit 1 ; else echo "Good start.going ahead."; fi

apt update && apt install tmux -y
password=$1
passwordfile='/etc/x11vnc.pass'
servicefile='/etc/systemd/system/x11vnc.service'
timerfile='/etc/systemd/system/x11vnc.timer'
script='/usr/bin/startxvnc'
apt-get update
apt-get install x11vnc net-tools -y
x11vnc -storepasswd $password $passwordfile



cat >$servicefile <<'EOT'
[Unit]
Description="x11vnc"
Requires=display-manager.service

[Service]
Type=simple
#Environment=XAUTHORITY=$(ps aux | grep -o -E "(-auth)(.*)(Xauth)[a-zA-Z]+")
#ExecStartPre=tmux new -s x11vnc -d
ExecStart=bash -c /usr/bin/startxvnc
#ExecStop=tmux kill-session -t x11vnc
Restart=on-failure
RestartSec=2

[Install]
WantedBy=graphical.target
WantedBy=multi-user.target


EOT


cat >$timerfile <<'EOT'
Unit]
Description=Wait for some time before running X11VNC

[Timer]
OnBootSec=5sec

[Install]
WantedBy=timers.target

EOT




cat >$script <<'EOT'
#!/bin/bash

getxauths()
{
xauths=()

ps aux | grep -o -E "(-auth)(.*)(Xauth)[a-zA-Z]+" | (while IFS= read -r xauth
do
xauths+=("$xauth")
done
printf "%s\n" "${xauths[@]}" | sort -u
) }


getpname()
{
#psp=$(ps -p $(lsof -t -i:5900) -o command)
psp=$(cat /proc/$(lsof -t -i:$1)/cmdline)
echo $psp
}

killproc()
{
pkill -9 $(lsof -t -i:$1)
echo "Killed by port $1"
}


starttmux()
{
xauth=$1
        tmux new -s $xauth -d
        tmux send-keys -t $xauth:0 "for (( ; ; )) ; do sleep 3s; ((disp ^= 1)) ; /usr/bin/x11vnc -display :\$disp -auth $xauth -rfbauth /etc/x11vnc.pass -shared -forever ; done" Enter

}

#echo $(getpname)
start() {
for (( ; ; )) ; do

#echo $psp
xauths=$(getxauths)
for xauth in $xauths ; do
xauth="$xauth" | xargs
if [[ ${xauth} != *"-auth"* ]];then
            unset tsessions
            tsessions=($(tmux list-sessions -F '#{session_name}'))

echo "tessions is " ${tsessions[@]} 

echo "xauth is " ${xauth}
        if [[ ! " ${tsessions[@]} " =~ " ${xauth} " ]]; then
starttmux $xauth


psp=$(getpname 5900)
echo $psp | grep -E -o "(-auth)(.*)(Xauth)[a-zA-Z]+" | (while IFS= read -r xold
do
sessionname=$(echo ${xold#"-auth"} | xargs)
#tmux kill-session -t "$sessionname"
        if [[ ! " ${tsessions[@]} " =~ " ${xauth} " ]]; then
            if [[ $psp == *"user/125"*  ]] ; then killproc 5900 ; tmux kill-session -t "$sessionname"  ; echo "session name is $sessionname" ;
             fi ; else starttmux $xauth ; sleep 30s ; fi
done)

        fi

fi


done

sleep 3s
done
}
start
EOT

chmod u+x $script
sed -i -e 's/WaylandEnable=true/WaylandEnable=false/g' /etc/gdm3/custom.conf 
sed -i -e 's/#WaylandEnable=false/WaylandEnable=false/g' /etc/gdm3/custom.conf 

systemctl daemon-reload
systemctl enable x11vnc.timer
systemctl stop x11vnc.service
systemctl disable x11vnc.service
systemctl restart x11vnc.timer
4
  • Can you explain all the things this script does? This will greatly enhance your answer.
    – user68186
    Apr 19 at 16:59
  • I've added some more info. It installs tmux, configures a service to manage the script which monitors x11vnc 's faults on the default wm on ubuntu 20/21. It provides a work around for the issue, ie not being able to connect before logging in.
    – Josh
    Apr 19 at 17:05
  • There is no Ubuntu 20/21, unless you are talking about Ubuntu Core 20 containers. Ubuntu desktop versions are numbered in the form YY.MM, where MM can be either 04, for April, or 10 for October.
    – user68186
    Apr 19 at 17:15
  • It's edited and updated now. It's meant for Ubuntu Desktop 20 or Ubuntu Desktop 21
    – Josh
    Apr 20 at 2:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.