I intstalled Ubuntu 12.04 to my HP mini 110. Everything working OK except my 3g modem. I read that others had driver issues but I think I have some other problem.

So after Ubuntu start it's asking my PIN code but after i type my PIN it's says Network disconnected when i try to connect again (clicking to Mobile network ON) it's says again Network disconnected. I think it's not trying to connect. My PIN is okay (i have an external USB modem for testing, when i insert this SIM card to this modem it's working!)

The type of the internal 3g modem is Hp lc2010 mobile broadband.

Please help.


EDIT: Finally i got the solution. Don't know that it's a HP mini 110 only or not but when the hardware Wifi button (F12) is turned off it's turning off the 3g too! After i turned on the wifi and entered my pin it's found the network and the connect is success!

  • BTW it's asking for PIN but i can't see this hardware when i type lshw – user1399448 Dec 17 '12 at 11:40

I recently solved similar problem on my Ubuntu by following this guide: http://en.newinstance.it/2010/01/08/3g-usb-stick-on-ubuntu/

  • Yes i read that and many other topics about this but looks like i have a different problem. i tried this: sudo modprobe usbserial vendor=0x19d2 product=0x0031 but after that the problem is the some. Looks like it's throwing the "network disconnected" box before it's really trying to connect – user1399448 Dec 17 '12 at 12:51
  • i tried sakis3g too. It says my hardware but can't see any network. The automatic search of networks is failed and in the "manual select" part i can't see any networks! (as i sad it's working with an external modem so no real problem with network) – user1399448 Dec 17 '12 at 12:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.