I have a 64-bit Windows 7 OS installed at the moment. I have used GPartEd to shrink the current Windows 7 partition on my 720GB HDD to 200GB. I have then made a new NTFS partition of 200GB which I will keep for later on as a shared drive between both Windows 7 and Ubuntu.

So in GPartEd I now have 3 partitions which were all automatically there from the Windows 7 installation, I only shrank the 3rd one from the 698GB or so that it was to 200GB and created the 200GB for the shared drive.

I first tried creating another 200GB partition at this stage to install Ubuntu too but when I burnt the DVD and loaded it, Ubuntu gave me no option to install alongside Windows, only the option to erase the entire disk and install Ubuntu on the blank drive...not what I want to do. So I tried installing it through clicking 'Something else', it downloaded all the install files but didn't install. I then had a lot of problems with getting the DVD drive to work and what not but now have this fixed so I can use Windows again.

So now I've used GPartEd to delete the partitions so again I'm now left with the 3 partitions there which Windows 7 automatically installs and a 200GB NTFS partition I will later use as a shared drive.

Booting up from the Ubuntu disc and again there is no option to install alongside Windows 7. How do I get it to do so? All I would like is Windows 7 and Ubuntu on a dual boot, with a 200GB NTFS partition to dump my work onto so that I can access it from both OS's.



/dev/sda1 - fat32 - /boot/efi - 100mb
/dev/sda2 - unknown - 128mb
/dev/sda3 - ntfs - 200gb
/dev/sda4 - ntfs - 297gb
/dev/sda5 - ext4 - / - 191gb
/dev/sda6 - linux-swap - 10gb

MBR partitioning scheme only supports 4 primary partitions, once you have all 4 of them you can't create any more of them.

To overcome this limitation, you need to create an extended partition, which can act as a container for a number of logical partitions.

You can then install Ubuntu into a logical partition.

  • Hi, see my updated OP please. I have installed ubuntu to sda5 here, sda3 contains my windows install and sda4 is an empty ntfs drive to use as the shared drive. It installed successfully and I am in Ubuntu, but there is no option to go to my windows OS anymore. I have tried installing grub/startupmanager but none of them install. Any ideas for me? – user1828314 Dec 16 '12 at 23:49
  • @user1828314: the listing of partitions you're showing is impossible with MBR so I suppose the drive is using GPT partitioning scheme, so what I've said in my answer doesn't apply. If you can boot into Ubuntu then GRUB is already installed, you don't need to install it. I'm not sure why Windows is not in GRUB's boot menu (or is it? Can you get to the menu?), it usually is added automatically during installation. – Sergey Dec 17 '12 at 0:28
  • I can get into the GRUB menu by holding shift at the boot, only ubuntu shows up. But I can see the windows "C: drive" from ubuntu so it is still there with all of its files there. I can also see the partitions all there still using GPartEd from within ubuntu. I'm lost at the moment – user1828314 Dec 17 '12 at 0:46
  • Please see this answer: askubuntu.com/a/110701/14564 – Sergey Dec 17 '12 at 0:51
  • Should this be entered at the terminal? The answer to this post doesn't tell where to enter this menuentry – user1828314 Dec 17 '12 at 0:57

I think that if you delete the new partitions and re-expand the Windows 7 partition, it may work. It should ask you to dual boot.

  • Hi please see my reply to Sergey above. Thanks for the help. – user1828314 Dec 16 '12 at 23:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.