I tried two different cat6 cables directly connected between my two ubuntu machines. This one I ordered online: http://www.amazon.co.uk/gp/product/B002SQPDXS/ref=wms_ohs_product only achieves 100mbit speeds, but does appear to be supporting cross-talk (direct pc to pc), the other cat 6 cable, worked perfectly and gets the full 1gigabit speed.

Both tests were performed using ftp and checking the network monitor with direct pc to pc connection.

Was the product description incorrect or do I need to manually set a setting somewhere in ubuntu for some cables? I had thought 10 quid for 20m of gigabit ethernet cable was a bit cheap, you get what you pay for.

Update: It seems that after rebooting, the device is set to 1000mbit sec when looking it up with

sudo ethtool eth0

However after a while, this will drop down to just 100, after which to reset it to 1000 again, I have to reboot, and simply unplugging and re-plugging in the cable doesn't do it.

I tried setting this in networking config file as suggested here:

auto eth0
iface eth0 inet static
pre-up /usr/sbin/ethtool -s eth0 speed 1000 duplex full

but that resulted in my networking failing to start. Is there a problem with my 'auto-negotiation'? Can I manually override a setting to 1000mbit?


I discovered that running the following commands 'solved' my problem:

sudo ethtool -s eth0 autoneg off
sudo ethtool -s eth0 speed 1000 duplex full 

I have been running the laptop for a couple of hours now and it hasn't switched down from 1gigabit (125MB/s) to 100mbit like it was before. I am assuming there is a problem with my auto-negotiation on the network. I realise, that networking speeds/issues depend on a lot of factors but it really does appear that overriding a configuration did the trick for me.

Hopefully this post will be useful to others who notice their cat6 connections start getting capped at 100mbit. There is probably another problem on the network and I have only fixed the 'symptom'.


This is a complicated question, with no simple answers ..

Any point-to-point transfer has to factor in all the possible elements that may limit speed, affect latency, or simply stop things from performing anywhere close to theoretical maximum.

I could probably make some educated guesses, at what might be causing your variance with different cables. But, that would take considerable time and require a lot more information that you have yet to supply.

Also, probably off subject for this forum.

Here is someone else's answer(s):

Whirlpool.net.au > Gigabit .. whats the actual transfer speed

Gigabit is up to 125MB/s

That is just maths, based on a theoretical 1 Gigabit/second, and 8bits in a byte.

You will never get 125MB/sec over gig eth. For a few reasons.

1) TCP overheads. Highest you'll ever see in an ideal world is around 100MB/sec.

2) Disk throughput. Your disk is likely to be the slowest link in the chain here – seek speeds, access speeds, they all play a part.

3) Machine I/O. If your PC is under load this will likely have an impact on transfer speeds.

  • Thank you for your answer. Just want to point out that you were mentioning 125MB/s speeds, but I am speaking in 'mbit' speeds (sounds 8 x faster). I have straightened out the cable, restarted machine, and re-plugged in the cable and recieved 1gig speeds over it again. It appears that somewhere/something is registering the connection at 100mbit for whatever reason. I have been using sudo ethtool eth0 to output the speed. Sometimes it states 100, sometimes it states 1000. – Programster Dec 16 '12 at 9:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.