I'm using vlc to capture an image from my webcam by running the following command:

cvlc v4l2:///dev/webcam --no-audio --run-time 5 --scene-path $PWD \
    --scene-replace --scene-format png --video-filter scene vlc://quit

. It works great except that I'm running this command in a cron job and it opens a player window for the duration of the capture, which gets in the way of me doing other stuff. Is there any way to hide this window? Can I tell vlc NOT to display this window whenever it runs? I looked at the help docs but couldn't find anything relevant in there.


2 Answers 2


turns out there's a dummy interface command-line flag, -Vdummy , which does the trick. Never mind!

  • 1
    This solution appears to no longer work.
    – fixer1234
    May 4, 2018 at 2:11

-Vdummy, the solution mentioned in the previous answer, seems to have been replaced by -Idummy See here.

  • You are answering a over 10 year old question. Of course things have changed. I suggest ancient questions like this are not ones that need new answers.
    – David
    Apr 9, 2023 at 6:40
  • new answers to old questions are perfectly acceptable and are preferable to duplicates each with frustratingly out-of-date answers. I've updated this question to mark this answer as the accepted one. thanks @hopefullyhelpful.
    – Dan O
    Apr 9, 2023 at 15:06
  • @DanO and hopefullyhelpful, I see that -Idummy is a MacOS flag. I don't see any reference to -Idummy in the Linux VLC CLI help documentation. Did you actually test out this flag and found it works?
    – hoatzin
    Apr 10, 2023 at 12:54
  • @David please read meta.stackexchange.com/a/125967/278859. StackExchange is not a normal "forum" and thus encourages answering old questions.
    – phil294
    Jul 19, 2023 at 5:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .