I'm the main user of my machine, but I want it to be usable by other members of my family too, without sharing passwords. The problem is there seems to be no (simple) way for someone to connect to the network. I configured a VPN connection and made it both connect automatically and available to all users. However, neither settings seems to have any effect:

  • When I login as my own user X, the connection is not up, but at least I can start it manually.
  • When logged in as another user and trying to start the connection, system asks for X password. However, even then it fails to start the connection (I don't know where to look for exact error, desktop popup is just generic "failed" message).
  • I tried to start connection as X, then relogin as a different user. This other user can then stop the connection without any password, but when trying to start again has the same problem as described in the previous paragraph.

Is this a known problem? Are there any workarounds or just misconfigurations on my part?

  • I have the same problem, though "available to all users" doesn't really apply for one user. – VedVals Dec 14 '12 at 18:44

1: That VPN connections do not auto-connect is a known problem.

"NetworkManager does not auto-connect to VPNs marked "Connect Automatically"


2: The other user possibly can't connect because they can't access credentials files stored in your home directory. Look in /etc/NetworkManager/system-connections/myvpncnnctn. Do you see file references in there such as cert=/home/X/openvpn/foo.crt? These may fail to be accessible to other users, e.g., because X's home directory is encrypted.

3: Failing that, it's possible the other user can't connect because the VPN password is stored in X's keyring. If this is your problem then change password-flags in the [vpn] section from 1 to 0 and add your password to the [vpn-secrets] section.


Double-check that the file in question is only readable by its owner (root).

Ref: https://bugzilla.redhat.com/show_bug.cgi?id=710552#c3

Similar question and answer: Connect/disconnect from VPN from the command line

  • 1) Understood; would be not much of a problem (just 2 clicks) if other users could connect manually. 2) My home directory is indeed encrypted, but the file you described (or anything in /etc/NetworkManager/...) doesn't reference it... The only suspicious entry in it is password-flags=1, or does that mean VPN connection password? – doublep Dec 14 '12 at 20:49
  • password-flag 1 means "(agent-owned) - a user-session secret agent is responsible for providing and storing this secret; when it is required, agents will be asked to provide it." I added a stanza to the answer with a suggestion for changing this. – jdthood Dec 14 '12 at 21:03
  • Thank you, point 3 worked fine. As a side note, people still wonder why Linux on desktop just isn't happening. So, here is one reason: GUI fails to do basic tasks for you and doesn't even provide meaningful error messages. – doublep Dec 14 '12 at 21:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.