4

Everytime I boot up my ubuntu 12.10, I get a black console screen.

I need to login in tty, and restart lightdm : sudo service lightdm restart

Then the GUI lightdm login screen appears as expected.

How to solve this annoying problem ?

Thank you.

2
  • Are you using the kernel from the proposed pocket? There was a bug that prevented the system to boot properly. – Andrea Corbellini Dec 14 '12 at 17:05
  • My kernel is 3.5.0-19-generic and my architecture 64bits. So I don't think i encountered this bug...anyway, I found a way to solve that annoying problem. Thank you. – Sulliwane Dec 15 '12 at 8:18
5

Finally, I solved the problem by :

  • installing GDM: sudo apt-get install gdm
  • choosing it by default: When asked, choose GDM as your default X windows manager
  • restarting: sudo reboot
  • Reverting to lightdm as default X window manager: dpkg-reconfigure lightdm

Ps : firing the command dpkg-reconfigure lightdm without having installed GDM before didn't solve my problem. So try installing GDM before.

1
  • same issue exists on 32-bit. i don't know how i got to this state, though. i had both gdm and lightdm before i tried your fix (changing to gdm and back to lightdm). – Jayen Dec 15 '12 at 9:06
1

This issue could be related to the use of a SSD.

If the first solution doesn't work for you, another workaround is to delay the startup of lightdm.

sudo nano /etc/init/lightdm.conf

and just BEFORE exec lightm, insert this single line :

sleep 2

Adjust the time (in seconds) depending on your needs (2 sec works for me). Save the file, and restart !

Found this solution here : http://www.webupd8.org/2013/01/ubuntu-lightdm-black-screen-when-using.html

2
  • I've had the same problem on two notebooks with SSD drives. I had to use sleep 2 (delay is not installed on my Ubuntu 12.10). – Carles Barrobés Mar 24 '13 at 23:06
  • oups, you're right. the command is sleep, and not delay. Updated ! thx – Sulliwane Mar 26 '13 at 0:00
0

If you are booting windows 7 and ubuntu 16.04 LTS i have same problem then i tried everything referred from sites.finally nothing is worked for me.
so one thing is worked for me.

  1. do not choose the default ubuntu os.
  2. click on advanced option for ubuntu
  3. choose the os option like "Ubuntu 16.04 .....(Systemed)"

this will boot your ubuntu os normally. and it works for me also it saves your time to everytime restart lightdm service.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.