Downloaded Ubuntu 12.04.1-alternate-amd64

Installed to USB stick

Integrity check fails on ./install/netboot/ubuntu-installer/amd64/pxelinux.cfg/default but that seems to be a known bug where the file isn't included in the alternative 64-bit ISO and shouldn't affect installation. I ignore it and proceed on.

For partitioning on 2 SSD Drives:

  1. Partition 300MB and 63GB on both
  2. RAID1 the 300MB and 63GBs
  3. Set the 300MB to EXT4 on /boot
  4. Encrypt the rest as MD1 and set it for LVM
  5. Create two volumes from MD1: 4GB swap and 59GB to /

I go through the installation and get to the point where it says everything is ready and to take the media out so as to boot from the drives

I receive the error "Error: No video mode activated." on startup

  • I've read that this can be solved by running "cp /usr/share/grub/*.pf2 /boot/grub" and then updating grub but I can't get to a place where I can actually run this command.
  • In rescue mode I can get to a shell from installer with /boot mounted to /target. So from there I can run "cp /cdrom/boot/grub/font.pf2 /target/grub/" but can't figure out a way to get it to update grub after that or know how what to change in manually updating the grub.cfg file. If I try other devices to mount the root filesystem I get the error "An error occurred while mounting the device you entered for your root file system".

It just sits on the video mode error and doesn't progress further. Googling around it seems like people see the error briefly before it continues booting, not getting stuck on it the way I am which leads me to believe that error may be unrelated to Ubuntu not booting.

So any ideas as to what I should try next or what needs to be done to install Ubuntu and get it to boot would be helpful.

Update 1: I tried Super Grub Boot Disk which resulted in getting

 Grub loading, please wait.
 Error 21

I found a set of fairly detailed instructions that seems to be what I'm trying to accomplish at: http://www.linuxbsdos.com/2011/05/10/how-to-install-ubuntu-11-04-on-an-encrypted-lvm-file-system/ Unfortunately, I still can't boot. The error I get now, trying to manually boot through Super Grub Boot Disk is "Error 15: File not found" when trying to find /etc/fstab

  • you could try the steps from a live cd, and chroot to the partiton of your ubuntu install, Have you had a chance to do that? – Vignesh Dec 19 '12 at 13:34
  • Pretty good idea, I dropped my USB stick yesterday and it stopped working. I'll have to wait until my new one comes in to try. – jchysk Dec 19 '12 at 17:42

I eventually got this working, but I'm still not completely sure what the problem was to begin with, so I'll list off the things I changed.

Instead of doing the software RAID through the installation software I did it with the Intel chipset options.

I ran into an issue where I couldn't install GRUB on the /boot because I had accidentally made that partition Logical instead of Primary, so I switched that.

I was using UNetBootin to create the bootable USB sticks and switched to Startup Disk Creator instead.

I switched from a 32gb USB stick to a 4gb USB stick for booting the Ubuntu and switched from Ubuntu Alternate to Ubuntu Desktop.

I still got the "No Video Mode Activated" error, but everything worked fine after these changes. I boot up to the decryption screen. Two boot options are in the BIOS though which is weird to me. They are "Ubuntu" and the name of my RAID. I need to choose Ubuntu for it to boot properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.