Not sure what happened here. I installed Cinnamon on my Ubuntu 12.10 environment yesterday, rebooted when finished and everything was working fine. I even used my WWAN modem after my fixed line broadband went down. However, after starting my machine this morning and seeing that my fixed line is still having problems (intermittently), I clicked the network applet and my WWAN device wasn't listed. It's not in the main network manager window either.

It is still present on the system, however:

$ lsusb
Bus 001 Device 003: ID 05ca:18b0 Ricoh Co., Ltd Sony Vaio Integrated Webcam
Bus 001 Device 004: ID 05c6:9221 Qualcomm, Inc. Gobi Wireless Modem (QDL mode)
Bus 002 Device 005: ID 04e8:6865 Samsung Electronics Co., Ltd 
Bus 002 Device 002: ID 0409:005a NEC Corp. HighSpeed Hub
Bus 003 Device 002: ID 147e:1000 Upek Biometric Touchchip/Touchstrip Fingerprint Sensor
Bus 008 Device 002: ID 044e:3017 Alps Electric Co., Ltd BCM2046 Bluetooth Device

Debug output from modem-manager, refers to a device that is blacklisted:

modem-manager[10186]:  [1355478137.024491] [mm-manager.c:866] device_added(): (tty/ttyUSB0): port's parent device is blacklisted
modem-manager[10186]:  [1355478137.024607] [mm-manager.c:875] device_added(): (tty/ttyS0): port's parent platform driver is not whitelisted
modem-manager[10186]:  [1355478137.024700] [mm-manager.c:875] device_added(): (tty/ttyS1): port's parent platform driver is not whitelisted

I couldn't see anything relevant in the debug output for network-manager, but I've created a paste for it just in case.

In /lib/udev/rules.d/77-mm-qdl-device-blacklist.rules, I found the following line that matches the device IDs from the lsusb output:

# Generic Gobi QDL device
ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9221", ENV{ID_MM_DEVICE_IGNORE}="1"

I tried commenting out the second line and restarting network-manager/modem-manager but it didn't help. I've no idea where to go from here, does anyone else have any ideas?



Mi Thinkpad has this modem, and now it works.

  1. Get a Windows with this driver (for Windows) working. If you don't have, want dual boot, you can try a VirtualBox installation. Get the drivers, and ensure it works with Windows.

  2. Install gobi-loader

    sudo apt-get install gobi-loader
  3. Copy these files, from windows to Linux

sudo mkdir /lib/firmware/gobi
sudo cp -p '/windows/c/Program Files/QUALCOMM/Images/Lenovo/UMTS/amss.mbn' /lib/firmware/gobi/
sudo cp -p '/windows/c/Program Files/QUALCOMM/Images/Lenovo/UMTS/apps.mbn' /lib/firmware/gobi/
sudo cp -p '/windows/c/Program Files/QUALCOMM/Images/Lenovo/6/UQCN.mbn' /lib/firmware/gobi/

Be careful because your Windows filesystem may vary


It should work

COMMENT: You can also, mount your Windows partition, if you want in /mnt and therefore pick these files from that place

| improve this answer | |
  • Re-installing gobi-loader was the first thing I tried, but no luck. I appreciate the help, though. – Andy E Dec 22 '12 at 22:57
  • On second thought, I think this may have worked. In any case, it is working now after I'd given up on it and left it for 2 weeks, I was looking at my lsusb output today and noticed it wasn't there, so I typed rfkill unblock all and it showed up again and started working. – Andy E Jan 8 '13 at 16:53
  • has anyone an idea what to do when there is no apps.mbn to copy? just uqcn.mbn and uqcn_nogps.mbn and in some subfolders amss.mbn... -- tried it with all versions, none worked! :-( – DJCrashdummy Feb 20 '16 at 19:11

I think you missed the part about manually copying the firmware files manually in the previous answer. I had a similar issue with a friend's netbook. It was an HP Mini 210–1076NR, but same gobi loader issue.

I blogged about it a while back, it was for Ubuntu 10.10: http://csgeek-random.blogspot.com/2011/02/hp-mini-2101076nr-ubuntu-netbook-1010.html

The relevant part though is probably this document:

Depending on your provider, you'd need a different firmware file. You won't need to re-install gobi-loader each time, but you'll probably need to reboot at least when you change firmwares. Try messing around with the files 'till you find the right one.

I'm not sure if those codes are unique to HP or not, I would go based on the HP document.. if all else fails, google around I'm sure whatever vendor you have will have a document on some cryptic website with this information.

Hope this helps.

| improve this answer | |
  • Thanks, I didn't miss that part though. I have the relevant firmware files in /lib/firmware/gobi. As I said in the question, everything was working fine before. No changes were made to gobi-loader or the firmware. – Andy E Dec 28 '12 at 12:36
  • try checking dmesg see if anything gobi related pops. I believe it should be creating a new device /dev/ttyUSB. If it isn't working, it should at least print something. – csgeek Dec 28 '12 at 20:43
  • 1
    Other things you could try. echo "\$GPS_START" > /dev/ttyUSB2 # use GPS echo "\$GPS_STOP" > /dev/ttyUSB2 gpscat /dev/ttyUSB2 that's assuming that your ttyUSB device is created. source: thinkwiki.org/wiki/Qualcomm_Gobi_2000 – csgeek Dec 28 '12 at 20:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.