Trying to install from CD desktop image and getting:

ata8.00: exception Emask 0x52 Sact 0x0 SErr 0xffffffff action 0xe frozen
ata8: SError: { blah blah }
ata8.00: failed command: IDENTIFY PACKET DEVICE
ata8.00: cmd blah blah
         res blah blah (ATA bus error)
ata8.00: status: { DRDY }
ata8: hard resetting link

My hardware: ASUS p8z77-v PRO with Samsung 830 256MB SSD

Please help!

  • Did you test burning another CD or running this CD from another computer ? When does it occurs exactly ? Does it occurs at a specific time in the process ? Please give us more info ! Dec 14, 2012 at 8:28
  • Yes, CD boots from another computer. This happens right after the purple screen. I escape to the options screen, get rid of the "silent splash" options on the boot command, then get this within the first ~30 lines of boot messages. The console is initialized and it looks like it's the first time it's looking for devices. Dec 14, 2012 at 16:20
  • Based on other info out there, I suspect it has something to do with my SSD, but I can't find any solutions. My SSD is already running Win7. My board has 8 SATA ports: 4 through an aux chip which I'll be using for RAID and 4 from the Z77 chipset. 2 of those are 6gb/s two are 3gb/s. I have the SDD on one of the 6gbs ports and the other will be used for another internal drive. The CD/DVD is on one of the 3gbs ports and the other will be used for an external port. Dec 14, 2012 at 16:25
  • Could this be a driver issue? If so, is there a repository where I could pull and update from and then how would I integrate that? Dec 14, 2012 at 16:27
  • Actually, I'm not quite sure exactly where this is happening as a bunch of messages scroll by in VGA mode, then the display reinitializes and I get nice pretty fonts, but only a few messages. The last one before the error is [drm] Initialized i915 ... at 5.8s. Then there's a long delay and I get the error at 35.1s. Dec 14, 2012 at 16:44

2 Answers 2


I just built a new computer and bumped into the same issue - and found an answer to it.

Most people seem to have symptoms of slow boot-up times, but I could not boot 90% of the times. When the system did boot, it seemed to work. If you do manage to boot, you should be able to trigger the problem with command: /lib/udev/ata_id --export /dev/sr0. Beware, if that truly is the problem, your system will freeze.

The command will send an ATAPI command to the optical drive. The problem is, the SATA controller (ASM1061 in your case) does not support these ATAPI commands, resulting in a frozen system.

There are two solutions to the issue:

  1. Copy the file /lib/udev/rules.d/60-persistent-storage.rules to /etc/udev/rules.d/60-persistent-storage.rules so that edits are not overwritten from updates. Remove the warning message at the top about not editing the file. Find the line containing word "ATAPI". Comment out the next line. This way, udev will not touch ATAPI. Save and run the command update-initramfs -u to finalize the changes.

  2. Change the SATA port for the optical drive. I used this method, as booting any Linux other than one with the modified udev rule results in freeze otherwise.

In my case, the motherboard is ASRock Z77 Extreme4 with the same ASMedia ASM1061 chip for two SATA3 ports. I had a DVD drive in one of them and got the error. Switched the DVD drive to a SATA port handled by the Z77 chip and everything works.

  • Holy boot, batman! That did the trick! Since I wrote this, I did find out it was a problem with ATAPI and the ASM1061, I just didn't know how to prevent libata from using ATAPI commands. I wasn't able to just switch ports as I'm using all of them for my RAID array and other devices. The only other thing I would add is that I read that after editing the rules, you should do a update-initramfs -u. Thanks!!!! Dec 24, 2012 at 17:57
  • When booting the Arch Linux live USB, I encountered the same issue with a DVD drive on the SATA3_A0 port of my ASRock Z87 Extreme4 motherboard. Switching the SATA3 port fixed the issue.
    – logion
    Jan 16, 2016 at 0:31

In my case I had to unplug my DVD ROM drive as it was in one of the SATA ports that was apparently causing the problem. But never the less works in Windows...

It may have also helped setting nouveau.modeset=0 at the end of the linux line in the pre boot settings as well as I had also been getting errors related to that. To do that you press "e" at the Grub menu to make this edit and press "F10" to apply and boot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .