9

I'm running Ubuntu 10.10 on my laptop using an external monitor. The monitor is connected by a HDMI cable. The external monitor does not have boxes, it does have an audio exit for a headphone/.. .

Now when I plug in my external monitor, I want to keep using my laptops boxes. Now it automatically sends the sound through the HDMI port instead.

I can easily change the appropriate settings in the sound configuration menu: I go to hardware and can select the device I want to use: Analog Surround 4.0 Output, instead of the HDMI one. This works and I can hear sound through my laptop boxes.

But I have to change this setting every time again when I plug in my external monitor, when I wake my laptop from the suspended state, etc.

How can I make this the default setting, without having to reset it all the time?

Thanks!

7

Ubuntu 10.10 is somehow not really up-to-date which makes it a bit hard to confirm the default pulseaudio installation there. However it may be worth to see if you have the module-switch-on-port-available loaded.

In case it is there, then try to disable it by commenting out (#) the following line in your /etc/pulse/default.pa:

# load-module module-switch-on-port-available

After the next restart of the pulseaudio server (e.g. with pulseaudio -k in a terminal) we should no longer switch to a different audio port when this becomes available (e.g. by plugging in your HDMI cable).

  • 2
    Ok thanks @Takkat that's exactly what I was looking for! – user1254962 Dec 13 '12 at 13:23
  • 2
    Five years later this is still relevant for Ubuntu 17.10 with Gnome (thanks). – Sander Verhagen Jan 28 '18 at 8:01
  • @Takkat I am on 18.04 w Gnome and mine switches from S/PDIF to HDMI, between uses, and between reboots. e.g I will watch youtube, then close the tab, come back later to watch another you tube and it is back on HDMI again. It could be swapping because my screen is going into locked state and I am having to login again but that still that is not good enough reason. I prefer the HDMI option but I want it to stay on my selection and not change randomly. I want to be able to, either set the default, or prevent it from switching. Can someone expand on this answer for a little more insight? – NZ Dev Feb 8 at 4:43
  • @NZDev You can try with defining a fallback device with pavucontrol. You may also try to remove conflicting user settings. – Takkat Feb 8 at 7:42

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.