Since yesterday, the title bars of windows are missing. I haven't changed any configuration.

I noticed 'Desktop Effects' set to none. Changing it back to 'Extra' made everything proper. I had to customize my desktop effects again in CompizConfig manager too. Now this problem reappears after every restart.

I must also say that, once I change Compiz settings all the three radio buttons in 'Desktop Effects' remain unselected. But when this problem arises, it will be set to 'None'.


Try to run fusion-icon at start-up, if you don't have it yet.

My effects disappeared, too.... so it must have been some package update (though I couldn't say which one). They came back after installing the latest nvidia drivers.

| improve this answer | |

This happens when compiz is not running.

compiz is the window manager that has all the desktop effects, so if it's not running, the windows won't have any decoration (title bar) and you won't see any effects.

I don't know why it would not run, though.

| improve this answer | |

I've noticed something similar happening on my work laptop recently. I don't yet know why this is occurring, but I've been opening a terminal and running compiz --replace as a short term fix.

| improve this answer | |

running the command "compiz --replace" worked for me as a fix for this issue.

all the same, i don't know why the problem happened in the first place. the system it happened on was a freshly installed 11.04 box, less than 24 hours before it started misbehaving.

i tried a virus scanner - no viruses detected. i ran e2fsck - the file system is clean. there is one bad sector on the hdd - since discovering that, the hdd was formatted and reformatted a few times before the installation, and the OS should not be writing to the bad sector, so this should not be a problem.

| improve this answer | |

i ran cat /var/log/syslog | less ... and this gave me a lot of data, and it stopped at a point where i noticed these two lines:

unity-window-de[5628]: segfault at ffffffff ip 009d7507 sp bf9e3e30 error 4 in libglib-2.0.so.0.2800.6[978000+d5000]


compiz[5618]: segfault at f ip 00b8333d sp bfeb24f4 error 4 in libpthread-2.13.so[b7b000+15000]

so i went into synaptic package manager and looked up libglib and reinstalled it. and as libpthread was not installed at all, i looked up compiz and found that one of the installed packages related to it controls the window frames so i reinstalled that package.

for now things seem to be working ... but i'll have to verify a little more before i know this is a fix.

update: after checking, i was able to upload via imagekind.com ... but flickr.com once again caused weird behavior in the browser and image select dialog box, and has caused the window frames (compiz) to fail. hopefully reinstalling the entire compiz package set will fix it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.