I'm using Ubuntu 12.10, on a TOSHIBA Satellite L755 laptop, and using a Cradlepoint MBR-1000 wireless router.

The wifi supposedly works fine on my sisters' and mom's laptops, and my dad uses a wired connection through the router. Nobody else has the problem.

It shows that I'm connected and everything. The network manager GUI shows that everything is going just dandy... but it's not. I'll be able to load a page or two, then I have to disconnect, and reconnect to the router to get it to work again for a couple minutes. I noticed when I was downstairs, close to the router, this problem seemed to go away (at least, I was connected for a couple of hours without running into this problem).

When I run

ping -n

it shows this while the connection is still running fine

64 bytes from icmp_req=1187 ttl=47 time=665 ms

and whe

  • 1
    I have this problem, too. I hope somebody comes out with a solution. – JamesTheAwesomeDude Dec 13 '12 at 2:02
  • and when the connection quits working, it outputs: From icmp_seq=178 Destination Host Unreachable – Collin Dec 13 '12 at 2:05
  • Do you have any info that you could share, James? Do you mind going into as much detail as you can? – Collin Dec 13 '12 at 2:07
  • Yeah: I'm using Ubuntu 12.04 LTS 64-bit with a D-Link DWA-160 adapter connected via WPA2 to a Belkin N300 Wi-Fi N router. (NOTE: the D-Link adapter is an old-scool D-link product, from back before they got bought out by Cisco. Their whole thing was that D-link products would be as non-proprietary as possible.) P.S. I have a dynamic IP, the Router's remote access is disabled, and the firewall is up, so don't even think about trying something ;P – JamesTheAwesomeDude Dec 13 '12 at 3:54
  • I'm using a dynamic IP also. That seems like that could help create a problem somewhere along the line. And, there's no way I could pull remote access hacking off. I did hack my school for an admin account though... – Collin Dec 13 '12 at 4:14

I was in network settings, and I noticed "Cloned MAC address" was left blank. At first, I changed the Device MAC address, AND the Cloned MAC address to be the same as the LAN MAC address. I thought this fixed it, because it lasted for about 30 minutes, before giving me the same issue. Although, this time, it gave me an error message that said "MAC address doesn't match (not exact words)". Then, I switched the Device MAC address back to it's original setting, and used that MAC address as the Cloned MAC address. This also seemed to work for a little bit. Then, instead of giving me the error in the terminal when runnging ping -n

From icmp_seq=178 Destination Host Unreachable

It just outputs:

ping: sendmsg: Network is unreachable

AND, it shows that it's not connected to wifi anymore. I think I may be on the right track to fixing this. Also, this "Network is unreachable error" may be because my dad turns the router off at night because the LEDs on it are too bright for him to sleep.

  • 1
    Something is causing my connection to the Internet, but not the router to time out, and not give any errors, reconnect, or show any obvious signs of where the error is coming from. – Collin Dec 13 '12 at 22:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.