I have had an AMD Radeon HD 6950 (i.e., Cayman series) for a couple years now, and I have tried a lot of combinations of drivers and settings with terrible results. I'm completely at a loss as to how to proceed. The open source driver has much better 2D performance, but it offloads all OpenGL rendering to the CPU.

What I've tried so far:

  • All the latest stable Ubuntu releases in the period, plus one Linux Mint release.
  • All the latest stable AMD Catalyst Proprietary Display Drivers, and currently 13.1.
  • The unofficial wiki installation instructions for every Ubuntu version and the semi-official Ubuntu instructions.
  • All the tips and tweaks I could find for Minecraft (Optifine, reducing settings to minimum), VLC (postprocessing at minimum, rendering at native video size), Catalyst Control Center (flipped every lever in there) and X11 (some binary toggles I can no longer remember).


  • Typically 13-15 FPS in Minecraft, 30 max (100+ in Windows with the same driver version).
  • Around 10 FPS in Team Fortress 2 using the official Steam client.
  • Choppy video playback, in Flash and with VLC.
  • CPU use goes through the roof when rendering video (150% for 1080p on YouTube in Chromium, 100% for 1080p H264 in VLC).
  • glxgears shows 12.5 FPS when maximized.
  • fgl_glxgears shows 10 FPS when maximized.

Hardware details from lshw:

  • Motherboard ASUS P6X58D-E
  • CPU Intel Core i7 CPU 950 @ 3.07GHz (never overclocked; 64 bit)
  • 6 GB RAM
  • Video card product "Cayman PRO [Radeon HD 6950]", vendor "Hynix Semiconductor (Hyundai Electronics)"
  • 2 x 1920x1200 monitors, both connected with HDMI.

I feel I must be missing something absolutely fundamental here. Is there no accelerated support for anything on 64-bit architectures? Does a dual monitor completely mess up the driver?

$ fglrxinfo
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 6900 Series
OpenGL version string: 4.2.11995 Compatibility Profile Context
$ glxinfo | grep 'direct rendering'
direct rendering: Yes

I am currently using the open source driver, with the following results:

  • Full frame rate and low CPU load when playing 1080p video.
  • Black screen (but music in the background) in Team Fortress 2.
  • Similar performance in Minecraft as the Catalyst driver. In hindsight obvious, since both end up offloading the rendering to the CPU.

My /var/log/Xorg.0.log after upgrading to AMD Catalyst 13.1. Some possibly important lines:

(WW) Falling back to old probe method for fglrx
(WW) fglrx: No matching Device section for instance (BusID PCI:0@3:0:1) found

The generated xorg.conf. The disabled "monitor" 0-DFP9 is actually an A/V receiver, which sometimes confuses the monitor drivers when turned on/off (but not in Windows). All three "monitor" devices are connected with HDMI.

Edit: Chris Carter's suggestion to use the xorg-edgers PPA (Catalyst 13.1) resulted in some improvement, but still pretty bad performance overall:

  • Minecraft stabilizes at 13-17 FPS, but at least the CPU load is "only" at 45-60%.
  • Still 150% CPU use for 1080p video rendering on YouTube in Chromium.
  • Massive improvement for 1080p H264 in VLC: 40-50% CPU use and no visible jitter
  • glxgears performance about doubled to 25-30 FPS when maximized.
  • fgl_glxgears still at ~10 FPS when maximized.
  • What is your Ubuntu version?
    – Melon
    Dec 17, 2012 at 11:12
  • @Melon Ubuntu desktop 12.10 x64.
    – l0b0
    Dec 17, 2012 at 12:28
  • Don't look at results from glxgears. They won't tell you much. Try running an OpenGL game, but without any web browsers or programs open. Also, try NOT TO USE Catalyst drivers. I've found them to be very buggy.
    – Melon
    Dec 19, 2012 at 10:31
  • @Melon: I have one game on Linux Steam, Team Fortress 2. That just shows a black screen (with background music) with open source drivers, and single digit FPS with Catalyst. AFAIK there are no other driver options.
    – l0b0
    Dec 19, 2012 at 12:06
  • Hm... Could you post your /var/log/Xorg.0.log file? Maybe this will tell us something...
    – Melon
    Dec 19, 2012 at 13:11

3 Answers 3


The best and most stable performance I have managed from my Radeon 5450 has been achieved by adding the xorg-edgers ppa found here

Having spent an age experimenting between fglrx proprietary drivers and AMD Catalyst drivers this has been one ppa I have no hesitation in adding.

enter image description here

  • After adding the ppa do sudo apt-get update && sudo apt-get dist-upgrade then choose fglrx (open source) from additional drivers Jan 29, 2013 at 16:14
  • Hm, that must be something new in 12.10 - I don't have the "Additional Drivers" tab in Software Sources. According to amdcccle I have "Driver Packaging Version" 9.012-121219a-151962C-ATI, which according to the unofficial wiki is Catalyst 13.1. Pretty bad performance (20-30 FPS in Minecraft), but for the first time my CPU is not at 100% all the time when playing.
    – l0b0
    Jan 30, 2013 at 20:52

One thing you may wish to do is COMPLETLY removal of fglrx drivers. Up to manual removal of any files that could be omitted.

Than installation of Mesa drivers (so you have anything more than VESA mode :P ).

And then fresh installation of drivers.

PS Do you have hybrid graphics under Windows? (That may mean special drivers from OEM)

  • I'm not sure how you could get more complete removal than documented in the canonical installation guide. Since I have installed multiple times, I have removed fglrx and installed Mesa between every driver reinstall. I have only one graphics card, as I said in the original question.
    – l0b0
    Jan 29, 2013 at 6:43
  • Did you tried to manually remove all directories created by fglrx?
    – przemo_li
    Jan 31, 2013 at 20:04

There is AMD Catalyst 12.12, released today that you can try, http://support.amd.com/us/gpudownload/embedded/Pages/embedded_linux.aspx It specifically fixes issues with X.Org 1.13.

  • That is the embedded Radeon Linux driver; the desktop driver is still at 12.10 / 12.11 beta.
    – l0b0
    Dec 13, 2012 at 18:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.