8

We use a wifi network at my school in which you must login with your student account in the web brower. When I boot my laptop with Windows 7, it redirects me automatically to the login page.

But if I use Ubuntu 12.10 I can connect to the wifi network, but it doesn't show the login page. I tried with Chrome and Firefox, but both browsers won't show any page.

Is there a solution to this problem?

3
  • This works for my Ubuntu 12.10 laptop without any special configuration. Have you tried refreshing the browser page? Can you add your Network Connection settings information by editing the question above? – user68186 Dec 12 '12 at 18:33
  • I have the same problem. Just to confirm that we have the exact same problem: did you try to copy the IP of the login page you get in Windows 7, and use it on the Ubuntu firefox? I did that and it worked, so the only problem was the automatic redirection that was not working. Is that the case for you too? – Ciro Santilli 新疆再教育营六四事件法轮功郝海东 Jun 12 '13 at 17:55
  • Have you tried using a different browser such as chromium? I did this now and it worked. – Ciro Santilli 新疆再教育营六四事件法轮功郝海东 Dec 28 '13 at 7:16
6

I had the same problem with Ubuntu 16.04. The hint to solving this was when I ran

sudo dhclient

and got the following message: /etc/resolvconf/update.d/libc: Warning: /etc/resolv.conf is not a symbolic link to /run/resolvconf/resolv.conf

The steps I took after that were from here: Resolvconf -u gives the error "resolvconf: Error: /etc/resolv.conf must be a symlink"

That is, running these steps solved the problem:

sudo rm /etc/resolv.conf
sudo ln -s /run/resolvconf/resolv.conf /etc/resolv.conf
sudo resolvconf -u

I hope this helps someone with the same problem.

2
  • This worked for me on a Linux Mint installation from mid-2016. I'm assuming the resolve.conf file was supposed to be regenerated based each time the network connection changed. – gymbrall Mar 16 '17 at 2:55
  • worked like a charm xubuntu 16.04 – Andrew Wei Jun 22 '17 at 8:38
4

Your problem may be bug #1003842

To fix this, with root privileges edit the file /etc/NetworkManager/NetworkManager.conf and comment out the line dns=dnsmasq: that is, put a # at the beginning of the line. Save the file. Then restart network-manager.

sudo service network-manager restart

Then reconnect to the Wi-Fi network.

1
2

I had this happen at a coffeeshop - I tried the suggested "sudo dhclient" above but got the error "RTNETLINK answers: file exists".

I wondered if I had an actual IP address yet, so I did an "ip addr show" which told me I did indeed have a successful DHCP - out of curiosity, I figured I'd see if that LAN "router" address was open - so typed in the 192.168.x.1 (where x is the subnet of that coffeeshop) - and boom, the browser showed the login page just like windows did.

So anyway, if you're stuck, this might work for you too. Thought I'd reply here because someone above helped me think about this with their dhclient comment.

2
  • 1
    Works most of the time, and I have had more luck with this in Firefox than other browsers. Some times I have found that it worked with 192.1.1, and 192.168.2.1, as well as 1.1.1.1 which is recommended in zapier.com/blog/open-wifi-login-page – Vass Feb 26 '19 at 15:46
  • @Vass This was the only solution that helped. Trying the above, my friend's apartment had a login page 1.1.1.1, and I had to go through that page a couple times, and I hit "if nothing happens, click here" and it finally worked. Thank you. – Joshua Detwiler Nov 4 '19 at 4:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.