So I've got a HP 6735b laptop.

When I installed Ubuntu 12.04 on it, I didn't have any wireless. After I downloaded the drivers via wired connection everything worked fine.

Now I've upgraded to 12.10 and I can connect to wireless, but it doesn't allow me to browse. I can also connect to wired internet, but that as well doesn't allow me to browse or do any update, install, upgrade.

I checked proxy settings and they are off. What is strange though, is that pinging to google.be gives: "ping: unknown host google.be"

but pinging to works as it should "PING ( 56(84) bytes of data."

pinging (google DNS) works without dropping a package or whatsoever.

I also tried it on another network and that doesn't work either.

Advice on how to fix?


Thx to maggotbrain and @spruyttej (on twitter) I was able to browse again.

Can you edit the file /etc/resolv.conf, adding the line nameserver to it and browse from your wired connection? – maggotbrain

The file maggotbrain talked about did not exist. So I did:

sudo nano /etc/resolv.conf

and then added nameserver to the file.

I rebooted and my internet was working. Though I wasn't certain whether this was a fix or a workaround.

on twitter @spruyttej told me to run:

sudo apt-get install resolvconf; sudo dpkg-reconfigure resolvconf;

This rewrote the /etc/resolv.conf file.

I'm now browsing happily. Thx guys!

  • 1
    Can you edit the file /etc/resolv.conf, adding the line nameserver to it and browse from your wired connection? Dec 12 '12 at 11:49
  • File didn't exist, adding that nameserver does make it work. Can I use this as a "fix" or is it just a workaround that I should only use temporary?
    – woutervddn
    Dec 12 '12 at 12:19
  • it works.. I've written an answer but can't post it (new account, can't post answer in first 8 hours)
    – woutervddn
    Dec 12 '12 at 12:28
  • I guess you can use this as a permanent fix, but the problem here is that you do not have proper DNS addresses: either obtained from your router/ISP if you are using DHCP, or set explicitly if static DNSes are required. Have a look at whether you can fix this with Network Connections.
    – Pavel A
    Dec 12 '12 at 12:32
  • @user114254 I would only consider that a temporary fix. You may have some other problems with your Network Manager and possibly the dnsmasq-base before you can get your wireless working. Your /etc/resolv.conf file should have been already present with a warning not to edit it. Dec 12 '12 at 12:33

As reported in bug #1000244 there are various circumstances under which the needed symbolic link /etc/resolv.conf -> ../run/resolvconf/resolv.conf fails to get created or gets deleted by misbehaving software. This can result in host name resolving failures.

As has already been mentioned, the solution is to ensure that resolvconf is installed correctly. The following commands

sudo apt-get install resolvconf
sudo dpkg-reconfigure resolvconf

should ensure this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.