I have a problem very similar to this guy: Desktop does not show when I installed nvidia drivers!. I have the same problem with the desktop not being present when I install choose the nvidia drivers from the software sources dialog.

I've trie the answer mark as the solution, but this doesn't help me. Still get the same result / bug.

I've also tried just to reconfigure it, like this guy says: http://ubuntuforums.org/showpost.php?p=12303179&postcount=4, but that didn't help me either.

Then someone suggested that I should try Bumblebee. I followed the installation (https://wiki.ubuntu.com/Bumblebee#Installation) and after the reboot the resolution was still crappy, but this time the desktop did show up, but with bad graphics and I couldn't use optirun and it turned out that bumblebee couldn't start.

I hope someone might know whats wrong or what I'm doing wrong.

I have a Lenovo W520 with a nvidia Quadro FX 880M and I'm running ubuntu 12.10


I also had this problem but after many days of trial and error this was the only solution that worked for me:

Go to a TTY (Control+Alt+F1)

  1. Log in
  2. sudo stop gdm to kill X
  3. sudo sh NVIDIA-Linux-x86_64-256.44.run (but replace this with the actual file)
  4. Assuming that goes well, it should build, install and load the kernel driver so just sudo start gdm to get back into X

Note: Ubuntu's driver will automatically rebuild the nvidia kernel module when it updates its kernel (security updates, etc). Unless you want to get involved in some serious scripting trickery, the manually installed one wont. So after kernel updates you'll likely be dumped at a low-resolution screen with a prompt on what to do next. Click exit to prompt (or the one that sounds like that) and do what you did starting from point 2.

Note on that Note: I recommend you never use the low graphics mode as it can disturb your desktop settings. Just get out of X, reinstall the driver and get back into X with full hardware capabilities.

Source: Good NVidia drivers for a GeForce GT 330M on a VAIO laptop?


Bumblebee is designed for computers with Optimus graphics. It may be possible your computer has Switchable graphics, which requires a different approach.

Perhaps you could do the following, to provide a bit more information:

  1. Print a list of hardware:

    sudo lshw -short

  2. Use the instructions on Leveno's website, to check whether you have Switchable or Optimus graphics:

Switchable vs. Optimus Graphics

  1. Check whether your computer works with 'vga_switcheroo' (for Switchable Graphics):

    ls -l /sys/kernel/debug/vgaswitcheroo/switch

More info on using VGA Switcheroo

The difference between Switchable and Optimus Graphics


For those who still got stuck with a broken Unity even when you're sure your Nvidia/ATI driver's now correct: I noticed that under another user account, evrything was fine, so it must be a user setting that got broken during the driver installations.

After doing 'dconf reset -f /org/compiz' the problem was solved (just had to reconfigure some compiz settings).


did you try this ?? Worked for me on 12.10 but now I am using 13.04 that did not have that problem at all

any way try giving this thing a go https://askubuntu.com/a/202587/42591


Reinstalled the system and the problem was gone :) Thanks for the input

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.