7

Additional details are:

OS = 12.10

Present Default Torrent Application = qBittorrent

Preferred Default Torrent Application = Vuze

My main area in of which I'm looking for advise is magnet links. Plus the program in question isn't 'installed' per say I have downloaded the tarball file for Vuze and I run the executable file from there to run it.

  • possible duplicate of How to set default program? – devav2 Dec 12 '12 at 6:11
  • Nope, that question is regarding things that are simple to set defaults for, this is for torrents, specifically magnet links. – BH2017 Dec 12 '12 at 8:19
9

I had the same problem and found a solution:

In escence you have to make sure your apps's .desktop file on:

/usr/share/applications

has this line:

MimeType=application/x-bittorrent;application/x-torrent;

and then add/edit this line on /usr/share/applications/defaults.list:

x-scheme-handler/magnet={$MYAPP}.desktop;

setting the correct app name of course.

Hope this can help.

3

Right click on the .torrent file > Properties > Open With (select Vuze), "set as default" and you're done.

You can always uninstall qbittorrent as well.

  • 2
    What about magnet files? I'd like to keep qBittorrent so I have a choice. Plus Vuze I don't have 'Installed' per say. I downloaded the tarball extracted the files and use the executable file to run the program. – BH2017 Dec 12 '12 at 7:25
3

Let me explain this again

Firstly we need to check that your program's ".desktop file" (in /usr/share/applications) has this line:

MimeType=application/x-bittorrent;application/x-torrent;

To check, open the text editor (called gedit) and hit "open" up to the left, then navigate to your program's .desktop file. As stated; you should find it in the folder /usr/share/applications. After you open it, search for "MimeType" (by pressing Ctrl+f and typing "MimeType" in the box that shows up).

...If you did find that it has this line then proceed. (if not then just paste the line wherever in between the lines. Or if you find the line incomplete then you can modify the existing line.) Close gedit.


Now that we've done the checking; open the file /usr/share/applications/defaults.list (the same way you opened the .desktop file). Search for "x-scheme-handler/magnet" (same way also). If you found it, make it look like this;

x-scheme-handler/magnet=YOURPROGRAM.desktop;

Replace YOURPROGRAM by the program you want to set default. The name must exactly match the name of your program's .desktop file.

example: x-scheme-handler/magnet=kde4-ktorrent.desktop;

And you're done!

Thanks to Adrian Matteo for the source.

  • that was awesome. thank you +1 :) – salmanwahed Jul 30 '15 at 17:53
  • This has no effect for me. Using Linux Mint 17.1, based on Ubuntu 14.04. Perhaps one has to restart for it to take effect. I was able to change the default by simply clicking the "select program" and choosing my program in /usr/bin/. – Deleet Sep 8 '16 at 16:51
1

Add the following line to ~/.local/share/applications/mimeapps.list

x-scheme-handler/magnet=vuze.desktop

Or If you are using Firefox go to Edit > Preferences > Applications change default application for magnet to vuze.

1

Within Ubuntu 18.xx, if you want to set e.g. Transmission to open magnet links by default, you can go with this within terminal:

gio mime x-scheme-handler/magnet transmission-gtk.desktop

Next time you'll be opening magnet links in any browser, set the browser to remember the action for xdg-open and transmission will open automatically.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.