10

I had been using Sublime Text 2 with no issues. I installed IDLE and now I'm unable to start Sublime Text. I tried uninstalling IDLE, but Sublime Text is still not starting. Here's the error:

Unable to load libgdk-x11-2.0.so
Unable to load gdk_cairo_create from libgdk-x11-2.0.so
Unable to load gdk_cursor_new_for_display from libgdk-x11-2.0.so
Unable to load gdk_cursor_unref from libgdk-x11-2.0.so
Unable to load gdk_error_trap_pop from libgdk-x11-2.0.so
Unable to load gdk_error_trap_push from libgdk-x11-2.0.so
Unable to load gdk_input_add from libgdk-x11-2.0.so
Unable to load gdk_input_remove from libgdk-x11-2.0.so
Unable to load gdk_keymap_translate_keyboard_state from libgdk-x11-2.0.so
Unable to load gdk_keyval_to_unicode from libgdk-x11-2.0.so
Unable to load gdk_pixbuf_new_from_file from libgdk-x11-2.0.so
Unable to load gdk_region_get_rectangles from libgdk-x11-2.0.so
Unable to load gdk_screen_get_default from libgdk-x11-2.0.so
Unable to load gdk_screen_get_display from libgdk-x11-2.0.so
Unable to load gdk_screen_get_height from libgdk-x11-2.0.so
Unable to load gdk_screen_get_rgb_colormap from libgdk-x11-2.0.so
Unable to load gdk_screen_get_rgba_colormap from libgdk-x11-2.0.so
Unable to load gdk_screen_get_root_window from libgdk-x11-2.0.so
Unable to load gdk_screen_get_width from libgdk-x11-2.0.so
Unable to load gdk_screen_get_n_monitors from libgdk-x11-2.0.so
Unable to load gdk_screen_get_monitor_geometry from libgdk-x11-2.0.so
Unable to load gdk_unicode_to_keyval from libgdk-x11-2.0.so
Unable to load gdk_window_get_frame_extents from libgdk-x11-2.0.so
Unable to load gdk_window_get_origin from libgdk-x11-2.0.so
Unable to load gdk_window_get_state from libgdk-x11-2.0.so
Unable to load gdk_window_invalidate_rect from libgdk-x11-2.0.so
Unable to load gdk_window_set_cursor from libgdk-x11-2.0.so
Unable to load gdk_window_move_resize from libgdk-x11-2.0.so
Unable to load gdk_x11_display_get_xdisplay from libgdk-x11-2.0.so
Unable to load gdk_x11_drawable_get_xid from libgdk-x11-2.0.so
Unable to load gdk_x11_get_server_time from libgdk-x11-2.0.so
Unable to load gdk_x11_get_xatom_by_name_for_display from libgdk-x11-2.0.so
Unable to load gdk_x11_window_set_user_time from libgdk-x11-2.0.so
Unable to load libgtk-x11-2.0.so
Unable to load gtk_accel_group_new from libgtk-x11-2.0.so
Unable to load gtk_accelerator_get_default_mod_mask from libgtk-x11-2.0.so
Unable to load gtk_box_get_type from libgtk-x11-2.0.so
Unable to load gtk_box_pack_start from libgtk-x11-2.0.so
Unable to load gtk_check_menu_item_get_type from libgtk-x11-2.0.so
Unable to load gtk_check_menu_item_new_with_label from libgtk-x11-2.0.so
Unable to load gtk_check_menu_item_set_active from libgtk-x11-2.0.so
Unable to load gtk_clipboard_clear from libgtk-x11-2.0.so
Unable to load gtk_clipboard_get from libgtk-x11-2.0.so
Unable to load gtk_clipboard_set_text from libgtk-x11-2.0.so
Unable to load gtk_clipboard_set_with_data from libgtk-x11-2.0.so
Unable to load gtk_clipboard_store from libgtk-x11-2.0.so
Unable to load gtk_clipboard_wait_for_text from libgtk-x11-2.0.so
Unable to load gtk_container_add from libgtk-x11-2.0.so
Unable to load gtk_container_get_children from libgtk-x11-2.0.so
Unable to load gtk_container_get_type from libgtk-x11-2.0.so
Unable to load gtk_container_remove from libgtk-x11-2.0.so
Unable to load gtk_dialog_add_button from libgtk-x11-2.0.so
Unable to load gtk_dialog_get_type from libgtk-x11-2.0.so
Unable to load gtk_dialog_run from libgtk-x11-2.0.so
Unable to load gtk_dialog_set_default_response from libgtk-x11-2.0.so
Unable to load gtk_drag_dest_set from libgtk-x11-2.0.so
Unable to load gtk_drag_finish from libgtk-x11-2.0.so
Unable to load gtk_file_chooser_add_filter from libgtk-x11-2.0.so
Unable to load gtk_file_chooser_dialog_new from libgtk-x11-2.0.so
Unable to load gtk_file_chooser_get_filename from libgtk-x11-2.0.so
Unable to load gtk_file_chooser_get_files from libgtk-x11-2.0.so
Unable to load gtk_file_chooser_get_type from libgtk-x11-2.0.so
Unable to load gtk_file_chooser_set_current_folder from libgtk-x11-2.0.so
Unable to load gtk_file_chooser_set_current_name from libgtk-x11-2.0.so
Unable to load gtk_file_chooser_set_do_overwrite_confirmation from libgtk-x11-2.0.so
Unable to load gtk_file_chooser_set_local_only from libgtk-x11-2.0.so
Unable to load gtk_file_chooser_set_select_multiple from libgtk-x11-2.0.so
Unable to load gtk_file_filter_add_pattern from libgtk-x11-2.0.so
Unable to load gtk_file_filter_new from libgtk-x11-2.0.so
Unable to load gtk_file_filter_set_name from libgtk-x11-2.0.so
Unable to load gtk_get_current_event_time from libgtk-x11-2.0.so
Unable to load gtk_im_context_filter_keypress from libgtk-x11-2.0.so
Unable to load gtk_im_context_set_client_window from libgtk-x11-2.0.so
Unable to load gtk_im_multicontext_new from libgtk-x11-2.0.so
Unable to load gtk_init from libgtk-x11-2.0.so
Unable to load gtk_main from libgtk-x11-2.0.so
Unable to load gtk_main_quit from libgtk-x11-2.0.so
Unable to load gtk_menu_attach_to_widget from libgtk-x11-2.0.so
Unable to load gtk_menu_bar_new from libgtk-x11-2.0.so
Unable to load gtk_menu_get_type from libgtk-x11-2.0.so
Unable to load gtk_menu_item_get_label from libgtk-x11-2.0.so
Unable to load gtk_menu_item_get_submenu from libgtk-x11-2.0.so
Unable to load gtk_menu_item_get_type from libgtk-x11-2.0.so
Unable to load gtk_menu_item_new_with_label from libgtk-x11-2.0.so
Unable to load gtk_menu_item_set_label from libgtk-x11-2.0.so
Unable to load gtk_menu_item_set_submenu from libgtk-x11-2.0.so
Unable to load gtk_menu_item_set_use_underline from libgtk-x11-2.0.so
Unable to load gtk_menu_new from libgtk-x11-2.0.so
Unable to load gtk_menu_popup from libgtk-x11-2.0.so
Unable to load gtk_menu_shell_append from libgtk-x11-2.0.so
Unable to load gtk_menu_shell_get_type from libgtk-x11-2.0.so
Unable to load gtk_message_dialog_new from libgtk-x11-2.0.so
Unable to load gtk_message_dialog_new_with_markup from libgtk-x11-2.0.so
Unable to load gtk_selection_data_get_uris from libgtk-x11-2.0.so
Unable to load gtk_selection_data_set_text from libgtk-x11-2.0.so
Unable to load gtk_separator_menu_item_new from libgtk-x11-2.0.so
Unable to load gtk_settings_get_default from libgtk-x11-2.0.so
Unable to load gtk_show_uri from libgtk-x11-2.0.so
Unable to load gtk_vbox_new from libgtk-x11-2.0.so
Unable to load gtk_widget_add_accelerator from libgtk-x11-2.0.so
Unable to load gtk_widget_add_events from libgtk-x11-2.0.so
Unable to load gtk_widget_destroy from libgtk-x11-2.0.so
Unable to load gtk_widget_get_display from libgtk-x11-2.0.so
Unable to load gtk_widget_get_parent from libgtk-x11-2.0.so
Unable to load gtk_widget_get_screen from libgtk-x11-2.0.so
Unable to load gtk_widget_get_type from libgtk-x11-2.0.so
Unable to load gtk_widget_get_window from libgtk-x11-2.0.so
Unable to load gtk_widget_grab_focus from libgtk-x11-2.0.so
Unable to load gtk_widget_hide from libgtk-x11-2.0.so
Unable to load gtk_widget_remove_accelerator from libgtk-x11-2.0.so
Unable to load gtk_widget_set_app_paintable from libgtk-x11-2.0.so
Unable to load gtk_widget_set_colormap from libgtk-x11-2.0.so
Unable to load gtk_widget_set_double_buffered from libgtk-x11-2.0.so
Unable to load gtk_widget_set_sensitive from libgtk-x11-2.0.so
Unable to load gtk_widget_show from libgtk-x11-2.0.so
Unable to load gtk_widget_show_all from libgtk-x11-2.0.so
Unable to load gtk_window_add_accel_group from libgtk-x11-2.0.so
Unable to load gtk_window_fullscreen from libgtk-x11-2.0.so
Unable to load gtk_window_get_type from libgtk-x11-2.0.so
Unable to load gtk_window_iconify from libgtk-x11-2.0.so
Unable to load gtk_window_maximize from libgtk-x11-2.0.so
Unable to load gtk_window_move from libgtk-x11-2.0.so
Unable to load gtk_window_new from libgtk-x11-2.0.so
Unable to load gtk_window_present_with_time from libgtk-x11-2.0.so
Unable to load gtk_window_remove_accel_group from libgtk-x11-2.0.so
Unable to load gtk_window_resize from libgtk-x11-2.0.so
Unable to load gtk_window_set_default_icon_list from libgtk-x11-2.0.so
Unable to load gtk_window_set_default_size from libgtk-x11-2.0.so
Unable to load gtk_window_set_keep_above from libgtk-x11-2.0.so
Unable to load gtk_window_set_modal from libgtk-x11-2.0.so
Unable to load gtk_window_set_position from libgtk-x11-2.0.so
Unable to load gtk_window_set_title from libgtk-x11-2.0.so
Unable to load gtk_window_set_transient_for from libgtk-x11-2.0.so
Unable to load gtk_window_set_type_hint from libgtk-x11-2.0.so
Unable to load gtk_window_stick from libgtk-x11-2.0.so
Unable to load gtk_window_unfullscreen from libgtk-x11-2.0.so
Unable to load cairo_clip from libcairo.so
Unable to load cairo_create from libcairo.so
Unable to load cairo_destroy from libcairo.so
Unable to load cairo_fill from libcairo.so
Unable to load cairo_font_options_create from libcairo.so
Unable to load cairo_font_options_destroy from libcairo.so
Unable to load cairo_font_options_set_antialias from libcairo.so
Unable to load cairo_get_source from libcairo.so
Unable to load cairo_image_surface_create from libcairo.so
Unable to load cairo_image_surface_create_for_data from libcairo.so
Unable to load cairo_image_surface_get_data from libcairo.so
Unable to load cairo_image_surface_get_format from libcairo.so
Unable to load cairo_image_surface_get_height from libcairo.so
Unable to load cairo_image_surface_get_stride from libcairo.so
Unable to load cairo_image_surface_get_width from libcairo.so
Unable to load cairo_line_to from libcairo.so
Unable to load cairo_matrix_init_scale from libcairo.so
Unable to load cairo_matrix_init_translate from libcairo.so
Unable to load cairo_matrix_translate from libcairo.so
Unable to load cairo_move_to from libcairo.so
Unable to load cairo_paint_with_alpha from libcairo.so
Unable to load cairo_pattern_set_extend from libcairo.so
Unable to load cairo_pattern_set_matrix from libcairo.so
Unable to load cairo_rectangle from libcairo.so
Unable to load cairo_reset_clip from libcairo.so
Unable to load cairo_restore from libcairo.so
Unable to load cairo_save from libcairo.so
Unable to load cairo_set_line_width from libcairo.so
Unable to load cairo_set_operator from libcairo.so
Unable to load cairo_set_source_rgb from libcairo.so
Unable to load cairo_set_source_rgba from libcairo.so
Unable to load cairo_set_source_surface from libcairo.so
Unable to load cairo_stroke from libcairo.so
Unable to load cairo_surface_destroy from libcairo.so
Unable to load cairo_surface_flush from libcairo.so
Unable to load cairo_translate from libcairo.so
Unable to load cairo_scale from libcairo.so
Unable to load pango_font_description_free from libpango-1.0.so
Unable to load pango_font_description_new from libpango-1.0.so
Unable to load pango_font_description_set_family from libpango-1.0.so
Unable to load pango_font_description_set_size from libpango-1.0.so
Unable to load pango_font_description_set_style from libpango-1.0.so
Unable to load pango_font_description_set_weight from libpango-1.0.so
Unable to load pango_font_get_metrics from libpango-1.0.so
Unable to load pango_font_map_load_font from libpango-1.0.so
Unable to load pango_font_metrics_get_ascent from libpango-1.0.so
Unable to load pango_font_metrics_get_descent from libpango-1.0.so
Unable to load pango_font_metrics_unref from libpango-1.0.so
Unable to load pango_language_get_default from libpango-1.0.so
Unable to load pango_layout_get_context from libpango-1.0.so
Unable to load pango_layout_get_pixel_extents from libpango-1.0.so
Unable to load pango_layout_set_font_description from libpango-1.0.so
Unable to load pango_layout_set_text from libpango-1.0.so
Unable to load pango_cairo_context_set_font_options from libpangocairo-1.0.so
Unable to load pango_cairo_create_layout from libpangocairo-1.0.so
Unable to load pango_font_map_create_context from libpangocairo-1.0.so
Unable to load pango_cairo_font_map_get_default from libpangocairo-1.0.so
Unable to load pango_cairo_show_layout from libpangocairo-1.0.so
Unable to load pango_cairo_update_layout from libpangocairo-1.0.so
Unable to load all required GTK functions
Unable to init px

Any solutions?

2
0

It looks like sublime is not able to find these libraries

libpango-1.0.so libcairo.so libgdk-x11-2.0.so libpangocairo-1.0.so 

do a locate

locate libpango-1.0.so libcairo.so libgdk-x11-2.0.so libpangocairo-1.0.so

If somehow these libraries are not present on your system, then install them again. If the error persists even after the install, then create a copy of the installed libraries and rename them to what sublime is expecting.

1
  • 3
    how's this usefull? ... so if i have the libraries installed i should destroy my applications only for using sublime ??!?! – Decebal Jan 3 '14 at 18:08
13

I had a similar error but I just had to issue sudo apt-get install libgtk2.0 and all the other dependencies were pulled automatically.

2
  • This is the only thing you need to do to run sublime on Ubuntu server. – nima Dec 30 '16 at 14:04
  • I had the same problem in Ubuntu 20.04. sudo apt-get install libgtk3.0 solved the issue. – Alish Dec 6 '20 at 8:50
5

In my case trying to run Sublime in a host without X-es gave me that error.

Installing following packages has solved the problem:

sudo apt-get install libgtk2.0-0 libgdk-pixbuf2.0-0 libfontconfig1 libxrender1 libx11-6 libglib2.0-0  libxft2 libfreetype6 libc6 zlib1g libpng12-0 libstdc++6-4.8-dbg-arm64-cross libgcc1 

(I haven't checked if ALL of them are really needed)

2
  • 1
    libstdc++6-4.8-dbg-arm64-cross to run Sublime Text? O.o – David Foerster Jan 7 '16 at 12:02
  • How is this not the accepted answer!? – cs01 Feb 24 '17 at 1:24
5

You installed a version of Sublime Text that does not match the processor architecture of your Ubuntu installation.

There are two downloads available, Ubuntu 64bit (also known as amd64) and Ubuntu 32bit (also i386). If the output of uname -a contains x86_64 you have a 64bit install of Ubuntu and should use the 64bit package of Sublime Text.

Just download the appropriate package and install it.

Note: The amd64 designation is a bit confusing. If you have a 64bit Intel processor you still use the amd64 packages.

4
  • 1
    Sorry for commenting on old post. Thanks for the tip. I got the same exact problem. And now I found out that my version of sublime text editor was i386/32 bit version. Uninstalled it, and reinstalled the 64 bit version and now everything works fine. – thuyein Mar 15 '15 at 11:06
  • Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) – David Foerster Jan 7 '16 at 11:55
  • This is the correct answer. The problems happens if you installed the wrong version of ST for your architecture. – mniess Sep 27 '16 at 21:09
  • I got this error without installing for the wrong system. @witkacy26's answer fixed the issue for me. – cs01 Feb 24 '17 at 1:25
0

Background and Short Answer

In my case, after opening a fresh shell instance, running subl works as expected. However, after making a number of modifications to LD_LIBRARY_PATH (and/or perhaps another library path environment variable), I suggest that you :

  1. clear said variables
  2. verify that Sublime now runs
  3. narrow down the offending package.

More Background and Long Answer

I really actually noticed the issue when building a software project that features several external packages: on the first build everything was fine, but subsequent builds would fail when installing MPICH. Because I modify LD_LIBRARY_PATH on subsequent builds based on what packages are already installed, the compiler was picking up on a library installed via PETSc rather than the system copy.

If you find yourself in a similar situation, it just might be that LD_LIBRARY_PATH (and/or other environment variables) is initially empty and that you need to set it to certain system paths before modifying it. For example, put export LD_LIBRARY_PATH="/usr/local/lib:/usr/lib/x86_64-linux-gnu:/usr/lib" in your shell profile configuration file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.