I downloaded Ubuntu V12.10 and burned it to a cd. I then booted my HP Pavilion m7750n from the cd and the install went smoothly. At the end of install the system advised that it was required to do a reboot, which it did. After rebooting I was presented with a purple/red screen for about 1/10 second, then the black screen with the following three lines of text:

[13.841736] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on [CRTC:10]
[13.841758] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on [CRTC:10]
[15.525126] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on [CRTC:10]

I read some posts in this Ubuntu forum and the only thing I could find comparable to my problem was dated in May 2012, but did not present a solution at the end. Also, it dealt with V12.04.

My question: Has any progress been made regarding this error message? If I've simply missed the resolution, could someone please point me in right direction. Thanks much. BJW>

  • Which posts? Can you add a link. – Mateo Dec 12 '12 at 3:19
  • Thanks, the answer got me further down the road. I have a 2006 HP Pavilion motherboard with built in video display controller. But I get lots of "internal error" dialogs when Ubuntu starts. I am now going to try an change the display controller settings, now that Ubuntu has actually been able to get going. – user140127 Mar 14 '13 at 3:06

I had the same problem on my machine. I was using the onboard video card NVidia chipset. (sorry, it's an old machine so I don't have all the details handy)

I put a cheap Asus Radeon HD 5450 pci-e card in and everything started working normally and booted.

I suspect the CRTC is related to the video driver and didn't the onboard chipset.


I have just encountered the same problem as well and this is how I fixed it:

  1. During the boot process, I held down the SHIFT Key (this is because my Ubuntu 12.04 LTS is the only OS) to get to the hidden GRUB Menu.
  2. Select the first entry (typically the default boot) and Press 'E' to edit the settings for the booting of the Kernel
  3. At the line that ends with "quiet splash", I appended "nomodeset"

I needed to do this as I was using an old nVidia card and have yet to install the required drivers. Do try it out, it might be the case that your video card drivers have not been installed as well.

Details of various other options can be found here:


Hope it helped! Cheers!

  • this seemed to have worked for me, magic – Alexander Mills Sep 15 '14 at 7:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.