2

I am an absolute newbie and struggling with Ubuntu! I am using Unity on 12.04 and where possible prefer to use GUI controls rather than terminal. In I can alter the repeat rate when a key is held down but can find no way to change the delay when repeating a key stroke as when typing double letters (allow, see. etc) At the moment I have to wait about 0.5sec before I can type the repeated letter! How can I speed this up? Have checked many other answers in the forums but cannot find this question.

  • Have you checked System Settings -> Keyboard -> Typing and tried changing the 'Repeat keys' values? I've never changed any keyboard settings and I don't have the half-second delay you describe. (You access the settings by clicking the little gear icon, very top right of the screen.) Note there are two different options for keyboard settings in that first menu, 'Keyboard layout' and 'Keyboard'. You want the second one. – Tom Brossman Dec 11 '12 at 21:11
  • @TomYes, as I said I have already tried changing the settings in 'keyboard' for both delay and speed – derek Dec 20 '12 at 10:02
4

I used xset. The following will show the current Repeat Rate Delay and the Repeat Rate:

xset q 

My default values were 200,33. The following will set the repeat rates:

xset r rate 500 33

The Repeat Rate Delay refers to the time it takes for a 2nd repeat character to appear when a character key is pressed down.

The Repeat Rate refers to the delay between the next repeat character to be displayed after the repeat rate delay has expired.

|improve this answer|||||
0

Open a terminal window (Alt+Ctrl+T) and type the following line:

xset r rate 500 33 

This will fix your problems, trust me. It fixed mine

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.