I tried re-installing it but it simply keeps giving me this error in a little window. When I close it, an identical error pops up some 3 seconds later without any new provocation.


Make sure steam isn't running at all in ~/.steam/.

  1. Delete ~/.steam/steam.pid

  2. Edit ~/.steam/registry.vdf line 29 from "Offline" "1" to "Offline" "0"


  • 1
    In my case, "Offline" was already set to "0" but Steam kept starting in Offline mode. Luckily, step 1 was enough to fix the issue. – Hubro Jul 21 '13 at 22:23
  • 1
    what is ~/.steam/steam.pid , is it some kind of directory where can i Find it – Sanjeev Dec 19 '15 at 18:57

This solved it for me

sudo apt-get install xfonts-75dpi xfonts-100dpi

Try it! if first time dont work, restart!

  • 3
    a combination of this and deleting ~/.steam/steam.pid did the trick for me. Also, ~/.steam/registry.vdf didn't exist – jairo Jan 11 '14 at 3:40

I have installed libnss-resolve:i386 by running the following command.

apt-get install libnss-resolve:i386

And now it works for me.


I am running Ubuntu 17.04 and the other answers didn't solve it. I had force an entry on /etc/hosts for media.steampowered.com.

So, first get the IP with

ping media.steampowered.com
# returns for me

then add that to /etc/hosts, like this: media.steampowered.com

And it should work as expected.


This is a solution that worked for me with (gnome 3) Ubuntu 17.04 Install the package libnss-resolve:i386 (sudo apt-get install libnss-resolve:i386)


In my case there was not enough space on the disk. At least 250MB are required. After freeing space, the install process started correctly.


I tried the above solutions, and while I was finally able to update the client,and log in, the problem I was facing. Actually being able to play a game (content server unreachable) was not possible.

I was able to solve the problem by adding steam1.steampowered.com To /etc/hosts file. And then launching steam from command line.

Hope this helps someone!


After following all solutions on this page, steam would still fail on first start after install.

Steam's cdn has stale files. In order to fix this, you must bypass all cdn's and directly download from the origin servers.

In order to do that, I've added the following to /etc/hosts: media.steampowered.com media1.steampowered.com media2.steampowered.com media3.steampowered.com media4.steampowered.com

The ip correponds to cdn-01-origin.steampowered.com.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.