A textbook I'm using came with a CD containing a few supplementary applications. To my pleasant surprise, it appears to include an installer for Linux.

The readme file on the CD provides the following installation instructions:

PC: Linux

  1. Double-click on the folder 'LINUX'
  2. Double-click on the file 'INSTALL.BIN'
  3. Follow instructions on screen.

But doing this just produces the following error message:

Could not display "/media/BDH DE/linux/install.bin". The file is of an unknown type

Attempting to run the installer via the command line results in a permissions error:

ak@aux:~$ ls /media/BDH\ DE/
linux  os x  readme.txt  windows xp  windows xp - no java
ak@aux:~$ ls -l /media/BDH\ DE/linux/
total 41177
-rw-r--r-- 1 ak ak 42164549 2005-07-26 03:39 install.bin
ak@aux:~$ /media/BDH\ DE/linux/install.bin
bash: /media/BDH DE/linux/install.bin: Permission denied

While, to my disappointment, the message fails to inform me of what permissions I am lacking, a quick glance at the output of ls reveals that the installer has not been marked executable.

How do I run it?

The type of the file is:

ak@aux:~$ file /media/BDH\ DE/linux/install.bin
src/bdh-de/install.bin: POSIX shell script text executable
  • 8
    What kind of file is it? 'file /media/BDH\ DE/linux/install.bin '? – user8290 Jan 22 '11 at 16:53
  • 1
    Ah-ha. Bizarrely, it is actually just a text file with a .bin filename extension. How aggravatingly misleading. – ændrük Jan 22 '11 at 18:50
  • 1
    Yeah - figured. So solved? Like if it's a shell script - you can 'bash /media/BDH\ DE/linux/install.bin' or something similar now? – user8290 Jan 22 '11 at 18:58

See what kind of file has been given a bin extension.

file $filename

If it's not binary data, it's text. So what program is to be used with this file?

head $filename

The first line might read #!/bin/bash. In that case run

bash $filename

to execute it. Or use whichever program for which the bin file was written, python, for example.

  • I still think how can i double click on the file and run it. It is still refusing to run if the file has '.bin' extension. – DTdev Jan 24 '17 at 6:03

If the problem is that CDROM was mounted 'noexec' you can remount it executable.

sudo mount -o remount,exec /media/BDH\ DE/
  • yeah, right, very good, worked well. – Silver Moon Jul 25 '13 at 13:56

If its not a script/text but a binary:

For 64-bit programs:

/lib64/ld-linux-x86-64.so.2 ./program.bin

For 32-bit programs:

/lib/ld-linux.so.2 ./program.bin


"To execute binaries, use /lib64/ld-linux-x86-64.so.2 ./program.bin for 64-bit programs and /lib/ld-linux.so.2 ./program.bin for 32-bit ones." – Comment from Lekensteyn on question https://askubuntu.com/a/17311/52853 Apr 13 2012


mount CDROM manually with umask=000, i.e.

sudo mount  -o umask=000 /dev/sdXY /mount_point

You can use one of both:

bash -c <command>


sh -c <command>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.